Memory Limit: 32 MB

Solve the equation:
        p*e-xq*sin(x) + r*cos(x) + s*tan(x) + t*x2 + u = 0
        where 0 <= x <= 1.

Input

Input consists of multiple test cases and terminated by an EOF. Each test case consists of 6 integers in a single line: pqrst and u (where 0 <= p,r <= 20 and -20 <= q,s,t <= 0). There will be maximum 2100 lines in the input file.

Output

For each set of input, there should be a line containing the value of x, correct upto 4 decimal places, or the string "No solution", whichever is applicable.

Sample Input


0 0 0 0 -2 1


1 0 0 0 -1 2


1 -1 1 -1 -1 1


Sample Output


0.7071


No solution


0.7554

求方程的零点,二分法。

#include<iostream>  
#include<algorithm>
#include<cmath>
#include<cstdio>
#include<string>
#include<cstring>
using namespace std;
int p, q, r, s, t, u, i;
double x;

double f(double x)
{
return p * exp(-x) + q* sin(x) + r * cos(x) + s* tan(x) + t * x * x + u;
}

int main(){
while (~scanf("%d%d%d%d%d%d", &p, &q, &r, &s, &t, &u))
{
if (f(0) * f(1) > 0) printf("No solution\n");
else {
double a = 0, b = 1;
while (a + 1e-8< b)
{
if (f((a + b) / 2) > 0) a = (a + b) / 2;
if (f((a + b) / 2) < 0) b = (a + b) / 2;
if (f((a + b) / 2) == 0) break;
}
printf("%.4lf\n", (a + b) / 2);
}
}
return 0;
}