Problem Description


Tom has learned how to calculate the number of inversions in a permutation of n distinct objects by coding, his teacher gives him a problem:
Give you a permutation of n distinct integer from 1 to n, there are many permutations of 1-n is smaller than the given permutation on dictionary order, and for each of them, you can calculate the number of inversions by coding. You need to find out sum total of them.
Tom doesn't know how to do, he wants you to help him.
Because the number may be very large, output the answer to the problem modulo  109+7.


 



Input


Multi test cases(about 20). For each case, the first line contains a positive integer n, the second line contains n integers, it's a permutation of 1-n.
n≤100


 



Output


109+7.


 



Sample Input


3 2 1 3 5 2 1 4 3 5


 



Sample Output


75

数位dp

#include<cstdio>
#include<cmath>
#include<queue>
#include<map>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn = 105;
const int base = 1000000007;
int n, a[maxn], u[maxn];
long long f[maxn], p[maxn], ans, tot, sum;

void get()
{
p[0] = 1;
for (int i = 1; i <= 100; i++)
{
f[i] = (i * f[i - 1] + p[i - 1] * i * (i - 1) / 2) % base;
p[i] = (p[i - 1] * i) % base;
}
}

int main()
{
get();
while (scanf("%d", &n) != EOF)
{
ans = tot = 0;
for (int i = 1; i <= n; i++) scanf("%d", &a[i]), u[i] = 1;
for (int i = 1; i <= n; i++)
{
sum = 0;
for (int j = 1; j < a[i]; j++)
if (u[j])
{
(ans += f[n - i] + p[n - i] * (tot+sum)) %= base;
sum++;
}

tot += sum;
u[a[i]] = 0;
}
cout << ans << endl;
}
return 0;
}