Permutation Counting
http://acm.hdu.edu.cn/showproblem.php?pid=3664
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1001 Accepted Submission(s): 496
Problem Description
Given a permutation a1, a2, … aN of {1, 2, …, N}, we define its E-value as the amount of elements where ai > i. For example, the E-value of permutation {1, 3, 2, 4} is 1, while the E-value of {4, 3, 2, 1} is 2. You are requested to find how many permutations of {1, 2, …, N} whose E-value is exactly k.
Input
There are several test cases, and one line for each case, which contains two integers, N and k. (1 <= N <= 1000, 0 <= k <= N).
Output
Output one line for each case. For the answer may be quite huge, you need to output the answer module 1,000,000,007.
Sample Input
Sample Output
1
4
Hint
There is only one permutation with E-value 0: {1,2,3}, and there are four permutations with E-value 1: {1,3,2}, {2,1,3}, {3,1,2}, {3,2,1}
Source
题意:求a[i]>i 的个数。。。。DP就ok了,,dp[i][j]表示为i个数排列E为j的个数
将第i个数插入到数组中,有三种情况:
①插入到末尾,则个数保持不变,为dp[i-1][j];
②与a[i]>i的交换,则个数亦保持不变,但有j中情况,共为dp[i-1][j]*j;
③与a[i]<i的交换,则个数增加1,有i-j种情况,共为dp[i-1][j-1]*(i-j);
状态转移方程:dp[i][j]=dp[i-1][j]+dp[i-1][j]*j+dp[i-1][j-1]*(i-j);
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int mod=1000000007;
int n,k;
long long dp[1010][1010]; //注意精度。。。dp[i][j]表示为i个数排列E为j的个数
int main(){
//freopen("input.txt","r",stdin);
for(int i=1;i<=1000;i++){ //打表,否则超时
dp[i][0]=1;
for(int j=1;j<=i;j++)
dp[i][j]=(dp[i-1][j]+dp[i-1][j]*j+dp[i-1][j-1]*(i-j))%mod;
}
while(~scanf("%d%d",&n,&k)){
cout<<dp[n][k]<<endl;
}
return 0;
}