Problem Description


FJ is going to do some shopping, and before that, he needs some boxes to carry the different kinds of stuff he is going to buy. Each box is assigned to carry some specific kinds of stuff (that is to say, if he is going to buy one of these stuff, he has to buy the box beforehand). Each kind of stuff has its own value. Now FJ only has an amount of W dollars for shopping, he intends to get the highest value with the money.


Input


The first line will contain two integers, n (the number of boxes 1 <= n <= 50), w (the amount of money FJ has, 1 <= w <= 100000) Then n lines follow. Each line contains the following number pi (the price of the ith box 1<=pi<=1000), mi (1<=mi<=10 the number goods ith box can carry), and mi pairs of numbers, the price cj (1<=cj<=100), the value vj(1<=vj<=1000000)


Output


For each test case, output the maximum value FJ can get


Sample Input


3 800 300 2 30 50 25 80 600 1 50 130 400 3 40 70 30 40 35 60


Sample Output


210


依赖背包,直接对每一个box进行01背包处理即可。


#include<stdio.h>

int main(){
int n, m;
int box[100], c[100][100], v[100][100],a[1000],b[1000];
while (scanf("%d%d", &n, &m) != EOF)
{
int ff[200000] = { 0 };
for (int i = 1; i <= n; i++)
{
scanf("%d%d", &box[i], &c[i][0]);
for (int j = 1; j <= c[i][0]; j++) scanf("%d%d", &c[i][j], &v[i][j]);
}
for (int i = 1; i <= n; i++)
{
int f[2000] = { 0 };
for (int j = 1; j <= c[i][0]; j++)
for (int k = 1000; k >= c[i][j]; k--)
if (f[k - c[i][j]] || k == c[i][j])
f[k] = f[k] < f[k - c[i][j]] + v[i][j] ? f[k - c[i][j]] + v[i][j] : f[k];
int p = 0;
for (int j = 0; j <= 1000; j++)
if (f[j]){ a[p] = j; b[p] = f[j]; p++; }
for (int k = m; k >=box[i]; k--)
for (int j = 0; j < p;j++)
if (k>=a[j]+box[i])
ff[k] = ff[k] < ff[k - a[j] - box[i]] + b[j] ? ff[k - a[j] - box[i]] + b[j] : ff[k];
}
printf("%d\n", ff[m]);
}
}