​HihoCoder - 1082​

#1082 : 然而沼跃鱼早就看穿了一切

1000ms


1000ms


256MB


描述

HihoCoder - 1082 然而沼跃鱼早就看穿了一切_不区分大小写

fjxmlhx每天都在被沼跃鱼刷屏,因此他急切的找到了你希望你写一个程序屏蔽所有句子中的沼跃鱼(“marshtomp”,不区分大小写)。为了使句子不缺少成分,统一换成 “fjxmlhx” 。

输入

输入包括多行。

每行是一个字符串,长度不超过200。

一行的末尾与下一行的开头没有关系。

输出

输出包含多行,为输入按照描述中变换的结果。

样例输入


The Marshtomp has seen it all before. marshTomp is beaten by fjxmlhx! AmarshtompB

样例输出


The fjxmlhx has seen it all before. fjxmlhx is beaten by fjxmlhx! AfjxmlhxB

让替换字符串(不区分大小写),直接暴力解决了。



#include<cstdio>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<iostream>
#include<vector>
#include<queue>
using namespace std;
const int maxn=1e5+5;
typedef long long ll;
char s[300];

int main()
{
while(gets(s))
{
int len=strlen(s); // fjxmlhx
for(int i=0;i<len;i++)// marshTomp
{
if((s[i]=='m'||s[i]=='M')&&(s[i+1]=='a'||s[i+1]=='A')&&(s[i+2]=='r'||s[i+2]=='R')&&(s[i+3]=='s'||s[i+3]=='S')&&(s[i+4]=='h'||s[i+4]=='H')&&(s[i+5]=='t'||s[i+5]=='T')&&(s[i+6]=='o'||s[i+6]=='O')&&(s[i+7]=='m'||s[i+7]=='M')&&(s[i+8]=='p'||s[i+8]=='P'))
{
printf("fjxmlhx");
i+=8;
}
else
printf("%c",s[i]);
}
printf("\n");
}
return 0;
}