Wormholes


Time Limit: 2000MS

 

Memory Limit: 65536K

Total Submissions: 39020

 

Accepted: 14340


Description


While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.


Input


Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.


Output


Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).


Sample Input


2 3 3 1 1 2 2 1 3 4 2 3 1 3 1 3 3 2 1 1 2 3 2 3 4 3 1 8


Sample Output


NO YES


Hint


For farm 1, FJ cannot travel back in time. 

For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.


//求有无负权回路(负环图)

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define INF 0xffffff
int n,ans;
int dis[5200];
struct Edge
{
int u,v,value;
}edge[5200];

bool bellman()
{
for(int i=0;i<n;i++)
{
bool flag=false;
for(int j=0;j<ans;j++)
{
if(dis[edge[j].v]>dis[edge[j].u]+edge[j].value)
{
dis[edge[j].v]=dis[edge[j].u]+edge[j].value;
flag=true;
}
}
if(!flag)
return false;
}
for(int i=0;i<ans;i++)
{
if(dis[edge[i].v]>dis[edge[i].u]+edge[i].value)
{
return true;
}
}
return false;
}
int main()
{
int test,m,w,u,v,t;
scanf("%d",&test);
while(test--)
{
scanf("%d%d%d",&n,&m,&w);
ans=0;
for(int i=0;i<m;i++)
{
scanf("%d%d%d",&u,&v,&t);
edge[ans].u=u;
edge[ans].v=v;
edge[ans++].value=t;
edge[ans].u=v;
edge[ans].v=u;
edge[ans++].value=t;
}
for(int i=0;i<w;i++)
{
scanf("%d%d%d",&u,&v,&t);
edge[ans].u=u;
edge[ans].v=v;
edge[ans++].value=-t;
}
if(bellman())
printf("YES\n");
else
printf("NO\n");
}
}