Wormholes


Time Limit: 2000MS Memory Limit: 65536K


Total Submissions: 32369 Accepted: 11762


Description


While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.


As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .


To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.


Input

Line 1: A single integer, F. F farm descriptions follow. 

Line 1 of each farm: Three space-separated integers respectively: N, M, and W 

Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 


Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.



Output


Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).



Sample Input

2

3 3 1

1 2 2

1 3 4

2 3 1

3 1 3

3 2 1

1 2 3

2 3 4


3 1 8



Sample Output

NO


YES



Hint

For farm 1, FJ cannot travel back in time. 


For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.



Source


USACO 2006 December Gold


题目大意:农场有N个点,M条双向边,每条边信息为——从S到E花费的时间为T,同理从T到S花费的时间

也为T。现在农场出现了W个虫洞,每个虫洞意味着:从S到E花费的时间为-T(时间倒流,但是虫洞是单向边)。

问:从N个点中的某点开始走,能否使时间倒流。

思路:构建一个图,添加M条双向边,再添加W个从S到E权值为-T的负权边,求最长路径,看能否出现负权

回路,若出现负权回路,则说明能使时间倒流,否则则不能使时间倒流。



#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
const int MAXN = 550;
const int MAXM = 5500;
const int INF = 0xffffff0;
struct EdgeNode
{
int to;
int w;
int next;
}Edges[MAXM];
int Head[MAXN],Dist[MAXN];

bool BellmanFord(int N,int M)
{
Dist[1] = 0;
for(int i = 1; i < N; ++i)
{
for(int j = 1; j <= N; ++j)
{
if(Dist[j] == INF)
continue;
for(int k = Head[j]; k != -1; k = Edges[k].next)
{
if(Edges[k].w != INF && Dist[Edges[k].to] > Dist[j] + Edges[k].w)
Dist[Edges[k].to] = Dist[j] + Edges[k].w;
}
}
}

for(int j = 1; j <= N; ++j)
{
if(Dist[j] == INF)
continue;
for(int k = Head[j]; k != -1; k = Edges[k].next)
{
if(Edges[k].w != INF && Dist[Edges[k].to] > Dist[j] + Edges[k].w)
return true;
}
}
return false;
}
int main()
{
int F,N,M,W,S,E,T;
scanf("%d",&F);
while(F--)
{
memset(Dist,INF,sizeof(Dist));
memset(Head,-1,sizeof(Head));
memset(Edges,0,sizeof(Edges));
scanf("%d%d%d",&N,&M,&W);
int id = 0;
for(int i = 0; i < M; ++i)
{
scanf("%d%d%d",&S,&E,&T);
Edges[id].to = E;
Edges[id].w = T;
Edges[id].next = Head[S];
Head[S] = id++;
Edges[id].to = S;
Edges[id].w = T;
Edges[id].next = Head[E];
Head[E] = id++;
}
for(int i = 0; i < W; ++i)
{
scanf("%d%d%d",&S,&E,&T);
Edges[id].to = E;
Edges[id].w = -T;
Edges[id].next = Head[S];
Head[S] = id++;
}
if(BellmanFord(N,M))
printf("YES\n");
else
printf("NO\n");
}

return 0;
}