Number Steps

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4960    Accepted Submission(s): 3013

Problem Description

Starting from point (0,0) on a plane, we have written all non-negative integers 0, 1, 2,... as shown in the figure. For example, 1, 2, and 3 has been written at points (1,1), (2,0), and (3, 1) respectively and this pattern has continued.




HDU 1391 Number Steps(数学题+找规律)_数学题+找规律




You are to write a program that reads the coordinates of a point (x, y), and writes the number (if any) that has been written at that point. (x, y) coordinates in the input are in the range 0...5000.

Input

The first line of the input is N, the number of test cases for this problem. In each of the N following lines, there is x, and y representing the coordinates (x, y) of a point.

 

Output

For each point in the input, write the number written at that point or write No Number if there is none.


Sample Input


34 2
6 6
3 4


Sample Output


612
No Number


Source

​Asia 2000, Tehran (Iran) ​

AC代码:




#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<algorithm>
#include<time.h>
typedef long long LL;
using namespace std;
int main()
{
int x,y,T;
scanf("%d",&T);
while(T--)
{
scanf("%d%d",&x,&y);
if(x==y)
x%2==1? printf("%d\n",x+x-1):printf("%d\n",x+x);
else if(x-y==2)
x%2==1?printf("%d\n",x+y-1):printf("%d\n",x+y);
else printf("No Number\n");
}
return 0;

return 0;
}