Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 22628    Accepted Submission(s): 5724

Problem Description

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.

Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.

Output

For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".

Sample Input

3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10

Sample Output

Case 1:
NO
YES
NO

Author

wangye

Source

​HDU 2007-11 Programming Contest​

Recommend

威士忌   |   We have carefully selected several similar problems for you:  ​​2199​​​ ​​2899​​​ ​​2289​​​ ​​1551​​​ ​​2298​​ 

题解:给你三组A、B、C的值和S值,问是否能找到Ai、Bj、Ck,使得Ai+Bj+Ck = S。
           二分,先将a数组和b数组,再相加成一个数组ab[500*500]。这样就相当于ab[i] + c[j] = s。
           再变形一下, ab[i] = s - c[j].
         只要在ab数组中用二分查找是否存在s-c[j]就可以了。

AC代码:

#include<iostream>
#include<algorithm>
#include<stdio.h>
using namespace std;
int a[505],b[505],c[505];
int ab[250005];
bool Binary_Search( int a, int l , int R )
{
//二分
if( l > R )
return false;
int mid = ( l + R ) / 2;
if (ab[mid] == a )
return true;
else if( ab[mid] > a)
Binary_Search( a, l, mid-1);
else
Binary_Search( a, mid+1, R);
}
int main()
{
int l,n,m;
int i,j,k;
int s,sum,cnt = 1;
while( cin >> l >> n >> m )
{

for( i = 0; i < l; i++)
cin >> a[i];

for( i = 0; i < n; i++)
cin >> b[i];

for( i = 0; i < m; i++)
cin >> c[i];

for(k=0, i=0;i<l; i++)
{
for( j=0; j<n; j++)
{
ab[k++] = a[i] + b[j];
}
}
sort( ab, ab + k );
cin >> s;
cout << "Case " << cnt++ << ":"<<"\n";
for( i = 0; i < s; i++ )
{
cin >> sum;
for( j = 0; j < m; j++)
if ( Binary_Search(sum-c[j] , 0 , k-1) ) //查找是否有满足的和
break;
if( j == m)
puts("NO");
else
puts("YES");
}
}
return 0;
}