Prime Cuts


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2490    Accepted Submission(s): 1093


Problem Description

A prime number is a counting number (1, 2, 3, ...) that is evenly divisible only by 1 and itself. In this problem you are to write a program that will cut some number of prime numbers from the list of prime numbers between (and including) 1 and N. Your program will read in a number N; determine the list of prime numbers between 1 and N; and print the C*2 prime numbers from the center of the list if there are an even number of prime numbers or (C*2)-1 prime numbers from the center of the list if there are an odd number of prime numbers in the list. 


Input

Each input set will be on a line by itself and will consist of 2 numbers. The first number (1 <= N <= 1000) is the maximum number in the complete list of prime numbers between 1 and N. The second number (1 <= C <= N) defines the C*2 prime numbers to be printed from the center of the list if the length of the list is even; or the (C*2)-1 numbers to be printed from the center of the list if the length of the list is odd. 


Output

For each input set, you should print the number N beginning in column 1 followed by a space, then by the number C, then by a colon (:), and then by the center numbers from the list of prime numbers as defined above. If the size of the center list exceeds the limits of the list of prime numbers between 1 and N, the list of prime numbers between 1 and N (inclusive) should be printed. Each number from the center of the list should be preceded by exactly one blank. Each line of output should be followed by a blank line. Hence, your output should follow the exact format shown in the sample output. 

Sample Input

21 2
18 2
18 18
100 7


Sample Output

21 2: 5 7 11

18 2: 3 5 7 11

18 18: 1 2 3 5 7 11 13 17

100 7: 13 17 19 23 29 31 37 41 43 47 53 59 61 67


 


Source

​South Central USA 1996​


Recommend

Eddy   |   We have carefully selected several similar problems for you:   ​​1124​​​  ​​​1395​​​  ​​​1327​​​  ​​​2421​​​  ​​​1214​​ 


​Statistic​​ | ​Submit​​ | ​Discuss​​ | ​Note​



题意就是找到1~N范围内的所有素数,如果素数的个数是奇数,那么输出中间的c*2-1个素数,否则输出中间的c*2个素数

首先把范围内的素数打表  根据输入输出数据即可

#include <stdio.h>
#include <math.h>
bool nprim[1005];
int count[1005];
int main()
{
for(int i=2;i<=sqrt(1005);i++)
{
if(!nprim[i])
for(int j=i*i;j<=1005;j+=i)
{
nprim[j]=true;
}
}
nprim[0]=true;
int cnt=0;
for(int i=1;i<1005;i++)
{
if(!nprim[i])
cnt++;
count[i]=cnt;
}

int n,c;

while(~scanf("%d %d",&n,&c))
{
int all=c*2;
if(count[n]%2==1)
all--;
int cut=(count[n]-all)/2;
bool first=true;
printf("%d %d: ",n,c);
for(int i=1;i<=n;i++)
{
if(cut>0&&!nprim[i])
{
cut--;
continue;
}
if(cut<=0&&!nprim[i])
{

if(!all) break;
all--;
if(first)
{
first=false;
printf("%d",i);
}
else
{
printf(" %d",i);
}
}
}
printf("\n\n");

}
return 0;
}