How many prime numbers




Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Total Submission(s): 12742    Accepted Submission(s): 4400



Problem Description


Give you a lot of positive integers, just to find out how many prime numbers there are.


 


Input


There are a lot of cases. In each case, there is an integer N representing the number of integers to find. Each integer won’t exceed 32-bit signed integer, and each of them won’t be less than 2.


 


Output


For each case, print the number of prime numbers you have found out.


 


Sample Input


3


2 3 4


 


Sample Output


2


 


Author


wangye


 


Source


HDU 2007-11 Programming Contest_WarmUp


题目大意:给你N个数,判断N个数里素数的个数。

思路:直接暴力来做。



#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;

int main()
{
int N,d;
while(cin >> N)
{
int sum = 0,j;
for(int i = 0; i < N; ++i)
{
cin >> d;
for(j = 2; j <= sqrt(1.0*d); j++)
{
if(d % j == 0)
break;
}
if(j > sqrt(1.0*d))
sum++;
}
cout << sum << endl;
}

return 0;
}