How Many Fibs?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6345    Accepted Submission(s): 2506


Problem Description

Recall the definition of the Fibonacci numbers: 

f1 := 1 

f2 := 2

fn := fn-1 + fn-2 (n >= 3)



Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b]. 

 

Input

The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.


Output

For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b. 


Sample Input

10 100
1234567890 9876543210
0 0

 


Sample Output

5
4

Source

​University of Ulm Local Contest 2000​


Recommend

Eddy   |   We have carefully selected several similar problems for you:   ​​1753​​​  ​​​1063​​​  ​​​1047​​​  ​​​1250​​​  ​​​1147​​ 

​Statistic​​​ | ​​Submit​​​ | ​​Discuss​​​ | ​​Note​


做了上个大数 没想到两道题的斐波那契数列初始化一个f[2]=1,一个f[2]=2不一样。。坑

import java.math.BigInteger;
import java.util.Scanner;

public class Main {

public static void main(String[] args) {
Scanner sca=new Scanner(System.in);
BigInteger f[]=new BigInteger[1005];
f[1]=BigInteger.ONE;
f[2]=new BigInteger("2");
for(int i=3;i<=1000;i++)
{
f[i]=f[i-2].add(f[i-1]);
}
while(sca.hasNext())
{
BigInteger l=sca.nextBigInteger();
BigInteger r=sca.nextBigInteger();
if(l.compareTo(r)==0&&l.compareTo(BigInteger.ZERO)==0) break;
int sum=0;
for(int i=1;i<=1000;i++)
{
if(f[i].compareTo(r)>0) break;
if(f[i].compareTo(l)>0&&f[i].compareTo(r)<0){
sum++;
}
if(f[i].compareTo(l)==0||f[i].compareTo(r)==0){
sum++;
}
}
System.out.println(sum);
}
}
}