N!Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4781    Accepted Submission(s): 2527

Problem Description

WhereIsHeroFrom:             Zty, what are you doing ?
Zty:                                     I want to calculate N!......
WhereIsHeroFrom:             So easy! How big N is ?
Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000…
WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao?
Zty:                                     No. I haven's finished my saying. I just said I want to calculate N! mod 2009


Hint : 0! = 1, N! = N*(N-1)!

Input

Each line will contain one integer N(0 <= N<=10^9). Process to end of file.



Output

For each case, output N! mod 2009


Sample Input

4 
5


Sample Output


24
120


Author


WhereIsHeroFrom


Source

​HDU女生专场公开赛——谁说女子不如男 ​


 




Recommend


lcy   |   We have carefully selected several similar problems for you:   ​​2672​​​  ​​​2668​​​  ​​​2673​​​  ​​​2669​​​  ​​​2671​​ 

​Statistic​​ | ​Submit​​ | ​Discuss​​ |​Note​


看到n的范围  脑子里就知道是规律。。。

其实把结果输出一下就看到了。如果某个值正好整除2009  那么 后面的都是0了

import java.math.BigInteger;
import java.util.Scanner;

public class Main {

public static void main(String[] args) {
// TODO Auto-generated method stub
Scanner sca=new Scanner(System.in);
while(sca.hasNext()){
int x=sca.nextInt();
if(x>41){
System.out.println(0);
continue;
}
BigInteger res=BigInteger.ONE;
for(int i=2;i<=x;i++){
res=res.multiply(BigInteger.valueOf(i));
res=res.mod(BigInteger.valueOf(2009));
}
System.out.println(res);
}
}

}