C - Integer Inquiry

Crawling in process...

Crawling failed

Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Submit ​​Status​​​ ​​​Practice​​​ ​​​POJ 1503​

System Crawler (2016-05-09)


Description


One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.)


Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative).

The final input line will contain a single zero on a line by itself.



Output


Your program should output the sum of the VeryLongIntegers given in the input.


Sample Input


123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0



Sample Output

370370367037037036703703703670



如果用java做要注意一个细节 就是判断为0的时候不能判断大数的整形值是不是等于0  要用一个中间值

import java.math.*;
import java.util.*;
public class Main {
public static void main(String[] args) {
Scanner scanner =new Scanner(System.in);
BigInteger sum=BigInteger.ZERO;
BigInteger temp2;
while(scanner.hasNext())
{
BigInteger temp=scanner.nextBigInteger();
temp2=sum;
sum=sum.add(temp);
if(temp2==sum){
System.out.println(sum);
break;
}
}
scanner.close();
}
}