目录

1.题目

Today is Ignatius’ birthday. He invites a lot of friends. Now it’s dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5

Sample Output
2
4
Sponsor

2.题意

处在一个朋友圈中的好友待在一张桌子上,问需要准备多少张桌子?

3.思路

并查集模板题。
链接: ​并查集模板.
链接: ​​​并查集学习​​.

4.代码

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxn = 5005;
int Fa[maxn], Rank[maxn];
void init(int n) ///初始化
{
for (int i = 1; i <= n; i++)
{
Fa[i] = i;
Rank[i] = 1;
}
}
int find(int x) //查找
{
return x == Fa[x] ? x : (Fa[x] = find(Fa[x]));//路径压缩
}
void merge(int i, int j) //按秩合并
{
int x = find(i), y = find(j);
if (Rank[x] <= Rank[y])
{
Fa[x] = y;
}
else
{
Fa[y] = x;
}
if (Rank[x] == Rank[y] && x != y)
{
Rank[y]++;
}
}

int main()
{

int n, m, T;
cin >> T;
while (T--)
{
cin >> n >> m;
init(n); ///初始化
int x, y;
for (int i = 1; i <= m; i++)
{
cin >> x >> y;
merge(x, y); //合并
}
int cnt = 0;
for (int i = 1; i <= n; i++)
{
if (Fa[i] == i)
{
cnt++;
}
}
cout << cnt<< endl;
}
return 0;
}