How Many Tables



Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)


Total Submission(s): 19654    Accepted Submission(s): 9785




Problem Description


Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.


 



Input


The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.


 



Output


For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.


 



Sample Input


2 5 3 1 2 2 3 4 5 5 1 2 5


 



Sample Output


2 4


 



Author


Ignatius.L


 



Source


​杭电ACM省赛集训队选拔赛之热身赛​


 



Recommend


Eddy   |   We have carefully selected several similar problems for you:   ​​1272​​​  ​​​1232​​​  ​​​1856​​​  ​​​1325​​​  ​​​1233​​ 


 




代码:


#include<cstdio>
using namespace std;

const int maxn=1e3;
int f[maxn+10];

int find(int x)
{
if(f[x]==x)return x;
return f[x]=find(f[x]);
}

int main()
{
// freopen("1.in","r",stdin);

int t,n,m,i,x,y,rx,ry;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
for(i=1;i<=n;i++)f[i]=i;
for(i=1;i<=m;i++)
{
scanf("%d%d",&x,&y);
rx=find(x),ry=find(y);
if(rx!=ry)f[rx]=ry,n--;
}
printf("%d\n",n);
}
return 0;
}