2281: Arithmetic Progressions

Submit Page    Summary    Time Limit: 5 Sec     Memory Limit: 256 Mb     Submitted: 225     Solved: 22    


Description

An arithmetic progression is a sequence of numbers a1, a2, ..., ak where the difference of consecutive members ai + 1 − ai is a constant 1 ≤ i ≤ k − 1 . For example, the sequence 5, 8, 11, 14, 17 is an arithmetic progression of length 5 with the common difference 3.

In this problem, you are requested to find the longest arithmetic progression which can be formed selecting some numbers from a given set of numbers. For example, if the given set of numbers is {0, 1, 3, 5, 6, 9}, you can form arithmetic progressions such as 0, 3, 6, 9 with the common difference 3, or 9, 5, 1 with the common difference -4. In this case, the progressions 0, 3, 6, 9 and 9, 6, 3, 0 are the longest.

Input

The input consists of a single test case of the following format.

n
v1 v2 ... vn

n is the number of elements of the set, which is an integer satisfying 2 ≤ n ≤ 5000 . Each vi(1 ≤ i ≤ n) is an element of the set,which is an integer satisfying 0 ≤ vi ≤ 109.vi's are all different, i.e.,vi ≠ vj if i ≠ j

Output

Output the length of the longest arithmetic progressions which can be formed selecting some numbers from the given set of numbers.

Sample Input

6
0 1 3 5 6 9

Sample Output

4

Hint

Source

说这是普通的dp,我咋感觉是区间dp,

2281: Arithmetic Progressions(dp)_动态处理

我咋感觉把d[i][j]理解为区间i到j内最长的等差数列更好呢?

这是我第一做区间dp的题,感觉又懂了一种动态处理最优答案的方法

AC代码:

#include <bits/stdc++.h>
using namespace  std;
typedef long long ll;

const int N=5e3+5;
int n;
int a[N],d[N][N];
int main(){
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
        scanf("%d",&a[i]);
    sort(a+1,a+1+n);
    for(int i=1;i<=n;i++)
    for(int j=1;j<=n;j++)
	d[i][j]=2;
    int ans=2;
    for(int i=2;i<=n-1;i++){
        int j=i-1,k=i+1;
	    while(j>=1&&k<=n){
	        if(a[j]+a[k]==2*a[i]){
	            d[i][k]=d[j][i]+1;
	            ans=max(ans,d[i][k]);
	            j--;k++;
	        }
	        else if(a[j]+a[k]<2*a[i])
	            k++;
	        else if(a[j]+a[k]>2*a[i])
	            j--;
	    }
	}
    printf("%d\n",ans);
}