Find The Multiple (水题)
原创
©著作权归作者所有:来自51CTO博客作者DWVictor的原创作品,请联系作者获取转载授权,否则将追究法律责任
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
#include<stdio.h>
bool vis;
void dfs( unsigned __int64 sum,int n,int k)
{
if (vis)return ;
if(sum%n==0)
{
printf("%I64u\n",sum);
vis=1;
return ;
}
if(k==19) return;
dfs(sum*10,n,k+1);
dfs(sum*10+1,n,k+1);
}
int main()
{
int n;
while(scanf("%d",&n)!=EOF&&n!=0){
vis=0;
dfs(1,n,0);
}
return 0;
}
2018-11-29