Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
题目大致意思就是找到只含有0和1的数同时能被n整除,dfs暴力就能过。
#include<iostream>
using namespace std;
bool flag;
unsigned long long ans;
void dfs(unsigned long long m,int n,int k)
{
if(flag)
{
return ;
}
if(k>19)
{
return ;
}
if(m%n==0)
{
flag=1;
ans=m;
return ;
}
dfs(m*10,n,k+1);
dfs(m*10+1,n,k+1);
}
int main()
{
int n;
while(cin>>n,n)
{
flag=0;
dfs(1,n,1);//~~我蒟蒻~~
cout<<ans<<endl;
}
}