题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1864
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Problem Description
现有一笔经费可以报销一定额度的发票。允许报销的发票类型包括买图书(A类)、文具(B类)、差旅(C类),要求每张发票的总额不得超过1000元,每张发票上,单项物品的价值不得超过600元。现请你编写程序,在给出的一堆发票中找出可以报销的、不超过给定额度的最大报销额。
Input
测试输入包含若干测试用例。每个测试用例的第1行包含两个正数 Q 和 N,其中 Q 是给定的报销额度,N(<=30)是发票张数。随后是 N 行输入,每行的格式为:
m Type_1:price_1 Type_2:price_2 ... Type_m:price_m
其中正整数 m 是这张发票上所开物品的件数,Type_i 和 price_i 是第 i 项物品的种类和价值。物品种类用一个大写英文字母表示。当N为0时,全部输入结束,相应的结果不要输出。
Output
对每个测试用例输出1行,即可以报销的最大数额,精确到小数点后2位。
Sample Input
200.00 3
2 A:23.50 B:100.00
1 C:650.00
3 A:59.99 A:120.00 X:10.00
1200.00 2
2 B:600.00 A:400.00
1 C:200.50
1200.50 3
2 B:600.00 A:400.00
1 C:200.50
1 A:100.00
100.00 0
Sample Output
123.50
1000.00
1200.50
Problem solving report:
这道题可以用01背包来做,也可以用贪心法,麻烦的是对发票的处理。
分析一下什么样的发票是不符合要求的:
1.某一种物品的和超过了600元,注意一定是和,因为有的物品出数据时故意分开了,这是一个坑。
2.发票中含有除ABC这三类的发票是不符合的。
3.发票中总额超过了1000元也是不符合的。
只要处理好上面这三点,AC就小意思了。剩下的就是一个01背包(或贪心),相当于让你求最大的价值。
01背包:
#include <bits/stdc++.h>
using namespace std;
int dp[3000005], money[55];
int main() {
char ch;
int n, t, k, tot, flag;
double a, b, c, q, total;
while (scanf("%lf%d", &total, &t), t) {
k = 0;
tot = (int)(total * 100);
memset(dp, 0, sizeof(dp));
while (t--) {
a = b = c = flag = 0;
scanf("%d", &n);
while (n--) {
scanf(" %c:%lf", &ch, &q);
if (ch != 'A' && ch != 'B' && ch != 'C' || q > 600) {
flag = 1;
break;
}
if (ch == 'A')
a += q;
else if (ch == 'B')
b += q;
else c += q;
}
if (!flag && a + b + c <= 1000 && a <= 600 && b <= 600 && c <= 600)
money[k++] = (int)((a + b + c) * 100);
}
for (int i = 0; i < k; i++)
for (int j = tot; j >= money[i]; j--)
dp[j] = max(dp[j], dp[j - money[i]] + money[i]);
printf("%.2f\n", (double)dp[tot] / 100.0);
}
return 0;
}
贪心:
#include <bits/stdc++.h>
using namespace std;
int cmp(double a, double b) {
return a > b;
}
int main() {
char ch;
int flag, n, t, k;
double a, b, c, q, ans, total, money[55];
while (scanf("%lf%d", &total, &t), t) {
k = ans = 0;
while (t--) {
a = b = c = flag = 0;
scanf("%d", &n);
while (n--) {
scanf(" %c:%lf", &ch, &q);
if (ch != 'A' && ch != 'B' && ch != 'C' || q > 600) {
flag = 1;
break;
}
if (ch == 'A')
a += q;
else if (ch == 'B')
b += q;
else c += q;
}
if (!flag && a + b + c <= 1000 && a <= 600 && b <= 600 && c <= 600)
money[k++] = a + b + c;
}
sort(money, money + k);
for (int i = k - 1; i >= 0; i--)
if (ans + money[i] <= total)
ans += money[i];
printf("%.2f\n", ans);
}
return 0;
}