Find The Multiple

Time Limit: 1000MS

 

Memory Limit: 10000K

Total Submissions: 32518

 

Accepted: 13601

 

Special Judge

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

大意:给出一个整数不超过200,求它任意一个只由1或0组成的数字(能整除给出的整数)

 

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std;
int n,flag;
void dfs(unsigned __int64 x,int k)
{
if(flag) return ;
if(x%n==0)
{
printf("%I64u\n",x);
flag=1;
return ;
}
if(k==19) return;// //为防止超出范围,循环深度应小于20
dfs(x*10,k+1);// //当前数字有两种选择方案,即下一个数选1或选0
dfs(x*10+1,k+1);
}
int main()
{
while(~scanf("%d",&n))
{
if(n==0) break;
flag=0;
dfs(1,0);
}
return 0;
}

  • 有符号型64位整数,值域为:-9223372036854775808 .. 9223372036854775807。

语言

GNU C/C++

Pascal

Visual C/C++

类型名称

__int64

or

long long

int64

__int64

输入方法

scanf("%I64d", &x);

or

cin >> x;

read(x);

scanf("%I64d", &x);

输出方法

printf("%I64d", x);


cout << x;

write(x);

printf("%I64d", x);

  • 无符号型64位整数,值域为:0 .. 18446744073709551615。

语言

GNU C/C++

Pascal

Visual C/C++

类型名称

unsigned __int64

or

unsigned long long

qword

unsigned __int64

输入方法

scanf("%I64u", &x);

or

cin >> x;

read(x);

scanf("%I64u", &x);

输出方法

printf("%I64u", x);

or

cout << x;

write(x);

printf("%I64u", x);