Zhejiang University has 【PAT (Advanced Level) Practice】1039 Course List for Student (25 分)_ios students and provides 【PAT (Advanced Level) Practice】1039 Course List for Student (25 分)_哈希表_02 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:
Each input file contains one test case. For each case, the first line contains 【PAT (Advanced Level) Practice】1039 Course List for Student (25 分)_#include_03 positive integers: 【PAT (Advanced Level) Practice】1039 Course List for Student (25 分)_排序_04, the number of students who look for their course lists, and 【PAT (Advanced Level) Practice】1039 Course List for Student (25 分)_排序_05, the total number of courses. Then the student name lists are given for the courses (numbered from 【PAT (Advanced Level) Practice】1039 Course List for Student (25 分)_ios_06 to 【PAT (Advanced Level) Practice】1039 Course List for Student (25 分)_排序_07) in the following format: for each course i, first the course index i and the number of registered students 【PAT (Advanced Level) Practice】1039 Course List for Student (25 分)_哈希表_08 are given in a line. Then in the next line, Ni student names are given. A student name consists of 【PAT (Advanced Level) Practice】1039 Course List for Student (25 分)_排序_09 capital English letters plus a one-digit number. Finally the last line contains the 【PAT (Advanced Level) Practice】1039 Course List for Student (25 分)_ios_10 names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:
For each test case, print your results in 【PAT (Advanced Level) Practice】1039 Course List for Student (25 分)_ios_10 lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

#include<iostream>
#include<unordered_map>
#include<vector>
#include<algorithm>

using namespace std;

int n, k;

unordered_map<string, vector<int>> mp;

int main(){

cin >> n >> k;

while(k--){

int id, m;
cin >> id >> m;

string name;
while(m--){

cin >> name;
mp[name].push_back(id);
}
}

string name;
while(n--){

cin >> name;

auto &v = mp[name];

sort(v.begin(), v.end());
cout << name << ' ' << v.size();

for(auto &t: v) cout << ' ' << t;
cout << endl;
}

return 0;
}