Given a sequence of K integers { N​1​​, N​2​​, ..., N​K​​ }. A continuous subsequence is defined to be { N​i​​, N​i+1​​, ..., N​j​​ } where 1. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21


 

Sample Output:

10 1 4


 



import Foundation

func fun1(array: [Int], num: Int){
var This = 0
var Max = 0
var arr2 = [Int](repeating: 0, count: num)
var arr3 = arr2
var s = 0
var count = 0

for i in array{
if i > -1{
break
}else{
count += 1
}
}

if count == num{
print(Max,array.first!,array.last!, separator: " ")
exit(0)
}
//判断输入数列是否全为负数

for i in array.indices {
This += array[i]
arr2[s] = array[i]
s += 1
//开始计算子列和,同时将最大子列保存在arr2数组中
if(This > Max){
Max = This
arr3 = arr2.filter({$0 != 0})
//arr3保存arr2过滤掉0的数列
}

if (This < 0){
This = 0
arr2 = [Int](repeating: 0, count: num - i - 1)
s = 0
}
}
print(Max,arr3.first!,arr3.last!, separator:" ")
}

let n = readLine()
//第一次输入
let s = Int(n!)!
//转换解包
var arr: [Int] = [Int](repeating: 0, count: s)
let words = readLine()!.components(separatedBy: NSCharacterSet.whitespaces)
//第二次输入:读取以空格为间隔的输入
arr = words.map {Int($0)!}
//放入数组
fun1(array: arr, num: s)