题目描述
输入输出格式
输入格式
输出格式
输入输出样例
输入样例 #1
11 8 7 1 5 3
输出样例 #1
2
说明
矩阵乘法模板题
由递推公式$X_{n+1}=(aX_n +c)\bmod m$
构造两矩阵
$$E_0 = \begin{Bmatrix}X_0 &c\end{Bmatrix}$$
$$V = \begin{Bmatrix}
a & 0\\
1 & 1
\end{Bmatrix}$$
$$E_0 * V^{n} = E_n = \begin{Bmatrix}X_n &c\end{Bmatrix}$$
直接上矩阵快速幂
注意乘积会爆 $long long$ 要用龟速乘
#include <bits/stdc++.h>
using namespace std;
long long m, a, c, X0, n, g;
long long calc(long long x,long long y)
{
long long res = 0;
while(y)
{
if(y & 1) res = (res + x) % m;
x = (x + x) % m;
y >>= 1;
}
return res;
}
struct Martix
{
long long f[4][4];
void clear()
{
memset(f, 0, sizeof f);
}
Martix operator*(const Martix b)
{
Martix c;
c.clear();
for(int i = 1; i <= 2; i++)
{
for(int j = 1; j <= 2; j++)
{
for(int k = 1; k <= 2; k++)
{
c.f[i][j] += calc(f[i][k] , b.f[k][j]);
c.f[i][j] %= m;
}
}
}
return c;
}
};
Martix E, V;
Martix qp(Martix a, long long b)
{
Martix res = V;
b--;
while(b)
{
if(b & 1) res = res * a;
a = a * a;
b >>= 1;
}
return res;
}
int main()
{
cin >> m >> a >> c >> X0 >> n >> g;
E.clear(); V.clear();
E.f[1][1] = X0; E.f[1][2] = c;
V.f[1][1] = a; V.f[1][2] = 0;
V.f[2][1] = 1; V.f[2][2] = 1;
E = E * qp(V, n);
cout << E.f[1][1] % g;
return 0;
}