Problem Description


Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.


 Input


The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.


 Output


For each test case, output the encoded string in a line.


 Sample Input



2


ABC


ABBCCC


 


Sample Output

ABC



A2B3C


 


题目意思:统计一个字符串相连字符出现个数。


解题思路:统计的字符必须是相连的,而不是统计一个字符串中某个字符出现的个数。


 


 




#include<stdio.h>
#include<string.h>
int main()
{
char x[10001];
int t,i,k,count;
scanf("%d",&t);
getchar();
while(t--)
{
count=1;
gets(x);
k=strlen(x);
for(i=0; i<k; i++)
{
if(x[i]==x[i+1])
count++;
else
{
if(count==1)
{
printf("%c",x[i]);
count=1;///每次清为1
}
else
{
printf("%d%c",count,x[i]);
count=1;
}
}
}
printf("\n");
}
return 0;
}