Description


Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string. 

2. If the length of the sub-string is 1, '1' should be ignored. 



 



Input



The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000. 



 



Output



For each test case, output the encoded string in a line. 



 



Sample Input



2 ABC ABBCCC



 



Sample Output


ABC
A2B3C

 



#include <stdio.h>
#include <string.h>
char s[10007];
int main()
{
    int n, i, k, x[999], j, h;
    scanf("%d ",&n);
    while(n--)
    {
        gets(s);
        k = strlen(s);
        h = 0;
        x[0] = 1;
        for(i = 0; i < k; i++)
        {
            if(i!=0)
            {
                if(s[i]==s[i-1])
                {
                    x[h]++;
                    for(j = i; j < k; j++)
                    {
                        s[j]=s[j+1];
                    }
                    i--;
                    k--;
                }
                else
                {
                    h++;
                    x[h]=1;
                }
            }
        }
        for(i = 0; i < k; i++)
        {
            if(x[i]!=1)
                printf("%d",x[i]);
            printf("%c",s[i]);

        }
        printf("\n");
    }
    return 0;
}