hdu 1019 Least Common Multiple
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29850 Accepted Submission(s): 11285
Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.
Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.
Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.
Sample Input
2
3 5 7 15
6 4 10296 936 1287 792 1
Sample Output
105
10296
/*第一种:(推荐)
*/
#include<cstdio>
int gcd(int a,int b)
{
return !b?a:gcd(b,a%b);
}
int lcm(int a,int b)
{
return a*b/gcd(a,b); //a*b/gcd(a,b)就错了 ,可能是 a*b 的值过大 ,应定义为long long类型吧。
}
int main()
{
int T,i,n;
scanf("%d",&T);
while(T--)
{
int a[1003];
scanf("%d",&n);
if(n==1)
{
scanf("%d",&a[0]);
printf("%d\n",a[0]);
}
if(n>=2)
{
for(i=0; i<2; i++)
scanf("%d",&a[i]);
long long r=lcm(a[0],a[1]);
for(i=2; i<n; i++)
{
scanf("%d",&a[i]);
r=lcm(r,a[i]);
}
printf("%I64d\n",r);
}
}
return 0;
}
/*
第二种:
*/
#include<cstdio>
int gcd(int a,int b)
{
return !b?a:gcd(b,a%b);
}
int main()
{
int T,i,n;
scanf("%d",&T);
while(T--)
{
int a[1003];
scanf("%d",&n);
if(n==1)
{
scanf("%d",&a[0]);
printf("%d\n",a[0]);
}
if(n>=2)
{
for(i=0; i<n; i++)
{
scanf("%d",&a[i]);
}
for(i=1; i<n; i++)
{
a[i]=a[i-1]/gcd(a[i-1],a[i])*a[i]; //同上 a[i]=a[i-1]*a[i]/gcd(a[i-1],a[i]) oj会判错
}
printf("%d\n",a[n-1]);
}
}
return 0;
}
hdu 1019 Least Common Multiple
原创
©著作权归作者所有:来自51CTO博客作者wx5f8d5a7b525f9的原创作品,请联系作者获取转载授权,否则将追究法律责任
提问和评论都可以,用心的回复会被更多人看到
评论
发布评论
相关文章
-
HDU 1019 Least Common Multiple(求最小公倍数)
Least Common MultipleTime Limit: 2000/100
HDU 1019 Least Common Multipl 最小公倍数 #include -
Least Common Multiple
Least Common MultipleProblem DescriptionThe le
printf 数据 测试 Java #include -
hdu 4913 Least common multiple 线段树
点值代表包含改点 且 lcm等于改点
线段树 #include i++ #define -
HDOJ 1019 Least Common Multipl…
题目:http://ac
#include i++ php