hdu 1196 Lowest Bit
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7731    Accepted Submission(s): 5677




Problem Description
Given an positive integer A (1 <= A <= 100), output the lowest bit of A.


For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.


Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.


 


Input
Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.


 


Output
For each A in the input, output a line containing only its lowest bit.


 


Sample Input
26
88
0
 


Sample Output
2
8




#include<cstdio>
#include<cmath>
int main()
{
    int m;
    while(scanf("%d",&m),m)
    {
        int s,i,t=0,a[10010],j=0;
        while(m)
{
            a[j++]=m%2;
            m/=2;
        }
        j--;
        while(a[t]==0)
{
            t++;
        }
       /*printf("%d\n",t);*/
       s=pow(2,t);
       printf("%d\n",s);
    }
    return 0;
}