Lowest Bit







Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)


Total Submission(s): 8043    Accepted Submission(s): 5920




Problem Description

Given an positive integer A (1 <= A <= 100), output the lowest bit of A.


For example, given A = 26, we can write A in binary form as 11010, so the lowest bit of A is 10, so the output should be 2.


Another example goes like this: given A = 88, we can write A in binary form as 1011000, so the lowest bit of A is 1000, so the output should be 8.

 

Input

Each line of input contains only an integer A (1 <= A <= 100). A line containing "0" indicates the end of input, and this line is not a part of the input data.

 

Output

For each A in the input, output a line containing only its lowest bit.

 

Sample Input

26

88

0

 

Sample Output

2

8

 

Author


SHI, Xiaohan


题目大意:给你一个数A,求它的二进制表示中最右边的1表示的数

比如:26的二进制表示为11010,最右边的1表示的数为00010。

思路:位运算,其实就是求A & (A ^ (A-1) ),即A & (-A)

比如:26——011010,-A = 111010  A & ()


#include<stdio.h>

int main()
{
int A;
while(~scanf("%d",&A) && A)
{
//int ans = A & ( A ^( A - 1));
int ans = A & (-A);
printf("%d\n",ans);
}
return 0;
}