Leftmost Digit
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12912    Accepted Submission(s): 4943

Problem Description

Given a positive integer N, you should output the leftmost digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the leftmost digit of N^N.

Sample Input

2
3
4

Sample Output

2
2

Hint

In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.

/* 题解:
 看题目可知N的位数非常大,常规方法根本无法做出来,故这里用到一个
 求N^N最高位a用到一个公式   a=10^(N*log10(N)-[N*log10(N)])  注:[N*log10(N)]为向下取整
 证明过程:
   用科学计数法来表示 N^N = a*10^x;
   比如 N = 3; 3^3 = 2.7 * 10^1;
   我们要求的最右边的数字就是(int)a,即 a 的整数部分;
   OK, 然后两边同时取以 10 为底的对数 lg(N^N) = lg(a*10^x) ;
   化简 N*lg(N) = lg(a) + x;
   继续化 N*lg(N) - x = lg(a)
   a = 10^(N*lg(N) - x);
   现在就只有 x 是未知的了,如果能用 n 来表示 x 的话,这题就解出来了。
   又因为,x 是 N^N 的位数。比如 N^N = 1200 ==> x = 3;
   实际上就是 x 就是 lg(N^N) 向下取整数,表示为[lg(N^N)]
   a = 10^(N*lg(N) - [lg(N^N)]);
   然后(int)a 就是答案
      */
#include<cstdio>
#include<cmath>
int main()
{
 double m;
 __int64 n;
 int T;
 scanf("%d",&T);
   while(T--)
    {
    scanf("%I64d",&n);
    m=n*log10(n+0.0);
    m-=(__int64)m;
    printf("%d\n",(int)pow(10,m));
   }
 return 0;
}