Leftmost Digit


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15786    Accepted Submission(s): 6154



Problem Description


Given a positive integer N, you should output the leftmost digit of N^N.


 



Input


The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).


 



Output


For each test case, you should output the leftmost digit of N^N.


 



Sample Input


2 3 4


 



Sample Output


Hint


#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#include<algorithm>
#define INF 0x3f3f3f3f
#define IN __int64
#define ull unsigned long long
#define ll long long
#define N 1010
#define M 1000000007
using namespace std;
int main()
{
	ll n;
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lld",&n);
		double x=n*log10(n);
		x-=(ll)x;
		int y=pow(10.0,x);
		printf("%d\n",y);
	}
	return 0;
}