Travel

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 5001    Accepted Submission(s): 1611


 

Problem Description

Jack likes to travel around the world, but he doesn’t like to wait. Now, he is traveling in the Undirected Kingdom. There are n cities and m bidirectional roads connecting the cities. Jack hates waiting too long on the bus, but he can rest at every city. Jack can only stand staying on the bus for a limited time and will go berserk after that. Assuming you know the time it takes to go from one city to another and that the time Jack can stand staying on a bus is x minutes, how many pairs of city (a,b) are there that Jack can travel from city a to b without going berserk?

 

 

Input

The first line contains one integer T,T≤5, which represents the number of test case.

For each test case, the first line consists of three integers n,m and q where n≤20000,m≤100000,q≤5000. The Undirected Kingdom has n cities and mbidirectional roads, and there are q queries.

Each of the following m lines consists of three integers a,b and d where a,b∈{1,...,n} and d≤100000. It takes Jack d minutes to travel from city a to city b and vice versa.

Then q lines follow. Each of them is a query consisting of an integer x where x is the time limit before Jack goes berserk.
 

 

 

Output

You should print q lines for each test case. Each of them contains one integer as the number of pair of cities (a,b) which Jack may travel from a to b within the time limit x.

Note that (a,b) and (b,a) are counted as different pairs and a and b must be different cities.

 

 

Sample Input

1 5 5 3 2 3 6334 1 5 15724 3 5 5705 4 3 12382 1 3 21726 6000 10000 13000

 

 

Sample Output

2 6 12

 

 

Source

​2015 ACM/ICPC Asia Regional Changchun Online​

 

 

Recommend

hujie   |   We have carefully selected several similar problems for you:  ​​6460​​​ ​​6459​​​ ​​6458​​​ ​​6457​​​ ​​6456​​ 

 

题意:

n个点,m条边的无向图,给出q次询问,每次给出一个值,求用到所有边权<=这个值的边的情况下,能够互相到达的点对的个数

分析:

首先,我们先按边的权值排序,因为这题的查询次数大,所以在线的并查集肯定超时,需要先将所有的查询的记录下来,保存查询权值和编号,然后按权值从小到大加入,加入该边每一个连通块的点数设为num[i],则现在相互能够到达的点数SUM(C(num,2)*2),

注意,如果两个联通块i和j合在一起的话,则变化量为2*[C(num[i]+num[j],2)-C(num[i],2)-C(num[i],2)]

 

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define N 20007

using namespace std;

int fa[N],num[N],t,n,m,q,ans
[N];
struct Query
{
int x,id;
}a[N];
struct Edge
{
int u,v,w;
}e[N*5];
void init ( )
{
for ( int i = 1 ; i <= n ; i++ )
{
num[i] = 1; ///记录连通块点的个数
fa[i] = i;
}
}

int _find ( int x )
{
return fa[x] == x? x : fa[x] = _find ( fa[x] );
}

void _union ( int x , int y )
{
x = _find ( x );
y = _find ( y );
if(x==y) return ;
fa[y] = x;
num[x] += num[y];
}
bool cmp(Edge a,Edge b)
{
return a.w<b.w;
}
bool cmp1(Query a,Query b)
{
return a.x<b.x;
}
int main ( )
{
scanf("%d" ,&t );
while ( t-- )
{
scanf ("%d%d%d",&n,&m,&q);
init();
for ( int i = 0 ; i < m ; i++ )
scanf ( "%d%d%d" , &e[i].u , &e[i].v , &e[i].w );
sort (e ,e+m,cmp);
int j = 0;
for ( int i = 0 ; i < q ; i++ )
{
a[i].id = i;
scanf ( "%d" , &a[i].x );
}
sort (a,a+q,cmp1);

int sum= 0;
for(int i=0;i<q;i++)
{
while (j<m&&e[j].w<=a[i].x )
{
int u=_find(e[j].u);
int v=_find(e[j].v);
j++;
if (u==v) continue;
sum+=(num[u]+num[v])*(num[u]+num[v]-1)-num[u]*(num[u]-1) - num[v]*(num[v]-1);
_union( u , v );
}
ans[a[i].id]=sum;
}
for ( int i = 0 ; i < q ; i++ )
printf ( "%d\n" , ans[i] );
}
}