: 5000MS         Memory Limit: 65536K
Total Submissions: 1348         Accepted: 448         Special Judge
Description

Signals of most probably extra-terrestrial origin have been received and digitalized by The Aeronautic and Space Administration (that must be going through a defiant phase: "But I want to use feet, not meters!"). Each signal seems to come in two parts: a sequence of n integer values and a non-negative integer t. We'll not go into details, but researchers found out that a signal encodes two integer values. These can be found as the lower and upper bound of a subrange of the sequence whose absolute value of its sum is closest to t. 

You are given the sequence of n integers and the non-negative target t. You are to find a non-empty range of the sequence (i.e. a continuous subsequence) and output its lower index l and its upper index u. The absolute value of the sum of the values of the sequence from the l-th to the u-th element (inclusive) must be at least as close to t as the absolute value of the sum of any other non-empty range.
Input

The input file contains several test cases. Each test case starts with two numbers n and k. Input is terminated by n=k=0. Otherwise, 1<=n<=100000 and there follow n integers with absolute values <=10000 which constitute the sequence. Then follow k queries for this sequence. Each query is a target t with 0<=t<=1000000000.
Output

For each query output 3 numbers on a line: some closest absolute sum and the lower and upper indices of some range where this absolute sum is achieved. Possible indices start with 1 and go up to n.
Sample Input

5 1
-10 -5 0 5 10
3
10 2
-9 8 -7 6 -5 4 -3 2 -1 0
5 11
15 2
-1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
15 100
0 0
Sample Output

5 4 4
5 2 8
9 1 1
15 1 15
15 1 15
Source

Ulm Local 2001
 
题意:
输入 n m  之后输入n个数 
之后m个询问  对于每个询问 输入一个t    输出  三个数 ans l r  表示从l 到 r的所有数的和的绝对值最接近t 且输出这个和ans

分析:

一般来说尺取法的条件我们必须要保证数列单调性。

我们要先预处理前缀和,根据前缀和大小进行排序。由于abs(sum[i]-sum[j])=abs(sum[j]-sum[i]),可以忽视数列前缀和的前后关系。此时,sum[r]-sum[l]有单调性。

单调性解决了。

我们要求一个子段的区间和接近t,不断地找比当前区间的和更大的区间,如果区间和已经大于等于t了,那么不需要在去找更大的区间了,因为其和与t的差值更大,然后区间左端点向右移动推进即可;否则,继续向右推进。

 

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<limits.h>
#include<math.h>
using namespace std;
typedef long long ll;
const int N=110000;
int n;
pair<ll,int>sum[N];
void find_(int t)
{
int i=0,j=1;
ll ans=1e18;
int l,v,r,temp,k;
while(j<=n&&ans)
{
temp=sum[j].first-sum[i].first;
if(abs(temp-t)<ans)
{
ans=abs(temp-t);
v=temp;
l=sum[i].second;
r=sum[j].second;
}
if(temp<t) j++;
if(temp>t) i++;
if(i==j) j++;
}
if(l>r)
{
temp=l;
l=r;
r=temp;

}
printf("%d %d %d\n",v,l+1,r);
}
int main()
{
int q,i;
while(scanf("%d %d",&n,&q)!=EOF)
{
if(n==0&&q==0) break;
ll sum1=0;
sum[0]=make_pair(0,0);
for(i=1;i<=n;i++)
{
ll x;
scanf("%lld",&x);
sum1+=x;
sum[i]=make_pair(sum1,i);
}
sort(sum,sum+n+1);
while(q--)
{
int t;
scanf("%d",&t);
find_(t);
}
}
return 0;
}