1089 Insert or Merge (25分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

 与​​PAT 1098​​题目类似 只不过 堆排序替换成了 归并排序

归并排序不用考虑中间序列了,直接对原来的序列进行模拟归并排序过程

i从0到n/k,每次一段sort(a + i * k, a + (i + 1) * k);最后别忘记还有最后剩余部分的sort(a + n / k * k, a + n)这样是一次归并的过程。

直到有一次发现a的顺序和b的顺序相同,则再归并一次,然后退出循环

#include <bits/stdc++.h>
#define Max 101
using namespace std;
int n;
int a[Max], b[Max];
int judge(){
int ind = 0;
for(int i = 1; i < n; i++){
if(b[i-1] <= b[i]) continue;
else {
ind = i; break;
}
}
for(int i = ind; i < n; i++){
if(a[i] != b[i]){
return -1;
}
}
return ind;
}
int main(){
cin >> n;
for(int i = 0; i < n; i++){
cin >> a[i];
}
for(int i = 0; i < n; i++){
cin >> b[i];
}
int pos = judge();
// cout << pos << endl;
if(pos != -1){
cout << "Insertion Sort" << endl;
sort(b, b+pos+1);
for(int i = 0; i < n; i++) {
cout << b[i];
if( i != n-1) cout << " ";
}
cout << endl;
}else {
cout << "Merge Sort" << endl;
int k = 1, flag = 1;
while(flag) {
flag = 0;
for(int i = 0; i < n; i++){
if(a[i] != b[i]) {
flag = 1;
}
}
k = k * 2;
for(int i = 0; i < n/k; i++){
sort(a + i * k, a + ( i + 1) * k);
}
sort(a + n / k * k, a + n);
}
for(int i = 0; i < n; i++){
cout << a[i];
if(i != n - 1) cout << " ";
}
cout << endl;
}
return 0;
}