1089 Insert or Merge (25 分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

本题需要对插入排序和归并排序具体步骤非常熟悉,明天全部重写一遍,专门一篇博客。考前仔细看看

#include<bits/stdc++.h>
using namespace std;
int N,a1[110],a2[110],b[110];
bool equal(int a[]){
for(int i=0;i<N;i++){
if(a[i]!=b[i]) return false;
}
return true;
}

void print(int a[]){
for(int i=0;i<N;i++){
if(i>0) cout<<" ";
cout<<a[i];
}
cout<<endl;
}

//归并 有序的[l1,r2]与有序的[l2,r2]归并
void merge(int a[],int l1,int r1,int l2,int r2){sort(a+l1,a+r2+1);}

int main(){
//freopen("in.txt","r",stdin);
cin>>N;
for(int i=0;i<N;i++){
cin>>a1[i];
a2[i]=a1[i];
}
for(int i=0;i<N;i++) cin>>b[i];
bool flag=false;
//归并排序
for(int step=2;step/2<N;step*=2){
for(int i=0;i<N;i+=step){
int mid=i+step/2-1;
if(mid+1<N){
merge(a1,i,mid,mid+1,min(N-1,i+step-1));
//i~i+step/2-1=>step/2个
//i+step/2~i+step-1=>step-1-step/2+1=step/2个
}
}
//一次step全排完算一趟
if(flag){
print(a1);
return 0;
}
if(equal(a1)){
cout<<"Merge Sort\n";
flag=true;
}
}
//能执行到这 说明flag一直是false
//插入排序
for(int i=1;i<N;i++){//小心 从1开始
int temp=a2[i];
int j=i;
while(j>0&&a2[j-1]>=temp){//j-1开始试
a2[j]=a2[j-1];
j--;
}
a2[j]=temp;
if(flag){
print(a2);
return 0;
}
if(equal(a2)){
cout<<"Insertion Sort\n";
flag=true;
}
}
return 0;
}