You have been employed by the organisers of a Super Krypton Factor Contest in which contestants have very high mental and physical abilities. In one section of the contest the contestants are tested on their ability to recall a sequenace of characters which has been read to them by the Quiz Master. Many of the contestants are very good at recognising patterns. Therefore, in order to add some difficulty to this test, the organisers have decided that sequences containing certain types of repeated subsequences should not be used. However, they do not wish to remove all subsequences that are repeated, since in that case no single character could be repeated. This in itself would make the problem too easy for the contestants. Instead it is decided to eliminate all sequences containing an occurrence of two adjoining identical subsequences. Sequences containing such an occurrence will be called “easy”. Other sequences will be called “hard”. For example, the sequence ABACBCBAD is easy, since it contains an adjoining repetition of the subsequence CB. Other examples of easy sequences are: • BB • ABCDACABCAB • ABCDABCD Some examples of hard sequences are: • D • DC • ABDAB • CBABCBA In order to provide the Quiz Master with a potentially unlimited source of questions you are asked to write a program that will read input lines from standard input and will write to standard output. Input Each input line contains integers n and L (in that order), where n > 0 and L is in the range 1 ≤ L ≤ 26. Input is terminated by a line containing two zeroes. Output For each input line prints out the n-th hard sequence (composed of letters drawn from the first L letters in the alphabet), in increasing alphabetical order (Alphabetical ordering here corresponds to the normal ordering encountered in a dictionary), followed (on the next line) by the length of that sequence. The first sequence in this ordering is ‘A’. You may assume that for given n and L there do exist at least n hard sequences. As such a sequence is potentially very long, split it into groups of four (4) characters separated by a space. If there are more than 16 such groups, please start a new line for the 17th group. Your program may assume a maximum sequence length of 80. For example, with L = 3, the first 7 hard sequences are: A AB ABA ABAC ABACA ABACAB ABACABA Sample Input 7 3 30 3 0 0 Sample Output ABAC ABA 7 ABAC ABCA CBAB CABA CABC ACBA CABA 28

大致的题意:就是你要输入一个n和L,分别代表前L个字母输出第n个小的困难的串,而困难的串就是其中没有连续重复的字符串

利用的方法就是回溯法

#include<bits/stdc++.h>
using namespace std;
int S[100],cnt;
int n,L;

int dfs(int cur){
    //输出当前的hard sequence
    //判断的条件是cnt为n 也就是第n个小的hard sequence
    if(cnt++==n){
        //cur是当前坐标长度
        for(int i=0;i<cur;i++){
            //注意格式
            printf("%c",'A'+S[i]);
            if(i%64==63 && i!=cur-1) printf("\n");
            else if(i%4==3 && i!=cur-1) printf(" ");

        }
        //输出长度
        printf("\n%d\n",cur);
        return 0;
    }
    //接下来的内容就是判断当前字符串是不是hard sequence
    for(int i=0;i<L;i++){
        S[cur]=i;
        int ok=1;
        for(int j=1;j*2<=cur+1;j++){ //后缀长度为j a(bcd)(bcd)
            //内循环检查 flag为equal
            //外循环检查 flag为 ok
            int equal=1;
            for(int k=0;k<j;k++) if(S[cur-k]!=S[cur-k-j]) {equal=0;break;}
            if(equal) {ok=0;break;}
        }
        if(ok) if(!dfs(cur+1)) return 0;
    }
    return 1;
}

int main(){
    while(cin>>n>>L && (n!=0 && L!=0)){
        cnt=0;
        dfs(0);
    }
    return 0;
}