An easy problem


Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15988    Accepted Submission(s): 10731

Problem Description


we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).


Input


On the first line, contains a number T.then T lines follow, each line is a case.each case contains a letter and a number.


Output


for each case, you should the result of y+f(x) on a line.


Sample Input


6 R 1 P 2 G 3 r 1 p 2 g 3


Sample Output


19 18 10 -17 -14 -4


#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
#define N 18
int main()
{
int t,y,sum;
char str[2];
// freopen("text.txt","r",stdin);
scanf("%d",&t);
while(t--)
{
scanf("%s%d",str,&y);
sum=0;
if(str[0]>='a'&&str[0]<='z')
{
sum-=str[0]-'a'+1;
sum+=y;
}else if(str[0]>='A'&&str[0]<='Z')
{
sum+=str[0]-'A'+1;
sum+=y;
}
printf("%d\n",sum);
}
return 0;
}