题目链接

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 10^10^) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3
题意:给定两个正整数n,k(n<=10^10,k<=100),若在k步内能否由n和本身反向相加得到一个回文数,则输出该回文数和步数,否则输出第k步得到的数和k.
思路:首先n的范围说明要用字符串,这里用string,方便回文数判断,剩下的就是大数和了。

代码:

#include <iostream>
#include <sstream>
#include <string>
#include <cstdio>
#include <queue>
#include <vector>
#include <algorithm>
using namespace std;
typedef long long ll;
const int N = 1e3+5;
const ll INF = 0x3f3f3f3f;
const double eps=1e-4;
const int T=3;

string str;
int k;
string add(string a,string b) {
    char ans[N]= {0};
    ans[N-1]='\0';
    int len=N-2;
    for(int i=a.length()-1; i>=0; i--,len--) {
        int tmp=ans[len]+a[i]-'0'+b[i]-'0';
        if(tmp>9) {
            ans[len]=tmp%10+'0';
            ans[len-1]++;
        } else {
            ans[len]=tmp+'0';
        }
    }
    if(ans[len]>0) {
        ans[len]+='0';
        len--;
    }
    return string(ans+len+1);
}
int main() {
    cin>>str>>k;
    bool flag=0;
    for(int i=0; i<k; i++) {
        string s=str;
        reverse(s.begin(),s.end());
        if(s!=str) {
            str=add(str,s);
        } else {
            flag=1;
            cout<<str<<"\n"<<i<<endl;
            break;
        }
    }
    if(!flag) {
        cout<<str<<"\n"<<k<<endl;
    }
    return 0;
}