/*

问题 1505: [蓝桥杯][算法提高VIP]单词个数统计

时间限制: 1Sec 内存限制: 128MB 提交: 82 解决: 35
题目描述
编写一个程序,输入一个字符串(长度不超过80),然后统计出该字符串当中包含有多少个单词。例如:字符串“this  is  a  book”当中包含有4个单词。

输入
输入一个字符串,由若干个单词组成,单词之间用一个空格隔开。
输出
输出一个整数,即单词的个数。
样例输入

this  is  a  book

样例输出

4

*/
#include<iostream>
#include<vector>
#include<string>
#include<sstream>
#include<cstdio>
using namespace std;
int main()
{
    char c[100];
    string s,word;
    vector<string> v;
    gets(c);
    s=c;
    istringstream ss(s);
    while(ss>>word)
    {
        v.push_back(word);
    
    }
    cout<<v.size();
    return 0;

}


有问题请下方评论,转载请注明出处,并附有原文链接,谢谢!如有侵权,请及时联系。