https://pintia.cn/problem-sets/994805342720868352/problems/994805444361437184
1041 Be Unique (20)(20 分)
Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 10^4^]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.
Input Specification:
Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=10^5^) and then followed by N bets. The numbers are separated by a space.
Output Specification:
For each test case, print the winning number in a line. If there is no winner, print "None" instead.
Sample Input 1:
7 5 31 5 88 67 88 17
Sample Output 1:
31
Sample Input 2:
5 888 666 666 888 888
Sample Output 2:
None
#include <iostream>
#include <cstring>
using namespace std;
const int nmax=1e4+10;
const int nmaxx=1e5+10;
int num[nmaxx];
int hashtable[nmax];
int main(int argc, char** argv) {
int n;
while(cin>>n){
//int num[n];
//int hashtable[nmax];
memset(num,0,sizeof(num));
memset(hashtable,0,sizeof(hashtable));
for(int i=0;i<n;i++){
cin>>num[i];
hashtable[num[i]]++;
}
int flag=0;
for(int i=0;i<n;i++){
if(hashtable[num[i]]==1){
cout<<num[i]<<endl;
flag=1;
break;
}
}
if(!flag){
cout<<"None"<<endl;
}
}
return 0;
}