1041. Be Unique (20)

时间限制


100 ms


内存限制


65536 kB


代码长度限制


16000 B


判题程序


Standard


作者


CHEN, Yue


Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1, 104]. The first one who bets on a unique number wins. For example, if there are 7 people betting on 5 31 5 88 67 88 17, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (<=105) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print "None" instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None


输出只出现一次的最早出现的或None

评测结果

时间

结果

得分

题目

语言

用时(ms)

内存(kB)

用户

8月06日

21:05

答案正确

​20​

​1041​

​C++ (g++ 4.7.2)​

26

728

​datrilla​

测试点

测试点

结果

用时(ms)

内存(kB)

得分/满分

0

答案正确

1

340

11/11

1

答案正确

1

308

1/1

2

答案正确

1

308

2/2

3

答案正确

1

308

2/2

4

答案正确

26

728

2/2

5

答案正确

26

724

2/2

#include <iostream>  
#define MAX 10000
#define L 100000
using namespace std;
int main()
{
int index;
int N;
int bet[L];
int bets[MAX] = {0};
bool Flag;
cin >> N;
for ( index = 0; index < N;index++)
{
cin >> bet[index];
bets[bet[index]]++;
}
Flag = true;
for (index = 0; index < N&&Flag; index++)
if (bets[bet[index]] == 1)
Flag = false;
if (Flag)cout << "None" << endl;
else cout << bet[index-1] << endl;
system("pause");
return 0;
}