Message Decowding


Time Limit: 1000MS

 

Memory Limit: 65536K

Total Submissions: 10326

 

Accepted: 5672


Description


The cows are thrilled because they've just learned about encrypting messages. They think they will be able to use secret messages to plot meetings with cows on other farms.

Cows are not known for their intelligence. Their encryption method is nothing like DES or BlowFish or any of those really good secret coding methods. No, they are using a simple substitution cipher.

The cows have a decryption key and a secret message. Help them decode it. The key looks like this:

yrwhsoujgcxqbativndfezmlpk



Which means that an 'a' in the secret message really means 'y'; a 'b' in the secret message really means 'r'; a 'c' decrypts to 'w'; and so on. Blanks are not encrypted; they are simply kept in place.



Input text is in upper or lower case, both decrypt using the same decryption key, keeping the appropriate case, of course.



Input


* Line 1: 26 lower case characters representing the decryption key

* Line 2: As many as 80 characters that are the message to be decoded


Output


* Line 1: A single line that is the decoded message. It should have the same length as the second line of input.


Sample Input


eydbkmiqugjxlvtzpnwohracsf Kifq oua zarxa suar bti yaagrj fa xtfgrj


Sample Output


Jump the fence when you seeing me coming


 字符串转换题不多说了。

#include<stdio.h>
main()
{
	char a[128],b[100],c[100];
	int i;
	int j=0;
	//freopen("in.txt","r",stdin);
	for(i='a';i<='z';i++)
	{
		scanf("%c",&a[i]);
	}
	for(i='a';i<='z';i++)
	{
		a[i-32]=a[i]-32;//复制到大写字母的区域 
	}
	getchar();
	gets(b);//输入需要转换的字符串 
	while(b[j]!='\0')//如果需要转换的字符串没有到达末尾继续转换 
	{
		if(b[j]==' ')//如果是空格,不转换 
		{
			c[j++]=b[j];
			continue;
		}
		c[j]=a[b[j]];
		j++;
	}
	c[j]='\0';//加上结束符 
	puts(c);
}