Recaman's Sequence
Description
The Recaman's sequence is defined by a0 = 0 ; for m > 0, a
m = a
m−1 − m if the rsulting a
m is positive and not already in the sequence, otherwise a
m = a
m−1 + m.
The first few numbers in the Recaman's Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9 ...
Given k, your task is to calculate a
k.
Input
The input consists of several test cases. Each line of the input contains an integer k where 0 <= k <= 500000.
The last line contains an integer −1, which should not be processed.
Output
For each k given in the input, print one line containing a k to the output.
Sample Input
7 10000 -1
Sample Output
20 18658
/*解题思路:
题目给出了一个序列的生成方法,求序列的第k个元素。
k不大,直接递推生成第K个元素就可以了。
生成过程中需要记录已经被生成的元素,可以用布尔数组打表记录
代码如下:
*/
#include<stdio.h>
int A[500005];
int table[3500000]={0};
void init()
{
int i,t;
A[0]=0;
for(i=1;i<=500000;i++)
{
t=A[i-1]-i;
if(t>0&&!table[t])
A[i]=t;
else
A[i]=A[i-1]+i;
table[A[i]]=1;
}
}
int main()
{
int n;
init();//初始化,打表
while(scanf("%d",&n) && n!=-1)//输入-1结束
{
printf("%d\n",A[n]);
}
return 0;
}