Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#service timestamps log datetime localtime
Router(config)#service timestamps debug datetime localtime
Router(config)#end
Router#
Router#
Router#
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#clock timezone EST 5 'clock timezone GMT 8 北京时间
Router(config)#end
Router#
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#clock summer-time EDT date 26 oct 2003 02:00 6 apr 2003 02:00
或者
Router(config)#end
Router#
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#clock timezone EST -5
Router(config)#clock summer-time EDT recurring
Router(config)#ntp server 172.25.1.1
Router(config)#end
Router#
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#clock timezone EST -5
Router(config)#clock summer-time EDT recurring
Router(config)#sntp server 172.25.1.1
Router(config)#end
Router#
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#clock timezone EST -5
Router(config)#clock summer-time EDT recurring
Router(config)#ntp server 172.25.1.1
Router(config)#ntp server 10.121.33.231
Router(config)#ntp peer 192.168.12.12
Router(config)#end
Router#
注释 无
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#clock timezone EST 5
Router(config)#clock summer-time EDT recurring
Router(config)#clock calendar-valid
Router(config)#ntp master 8
Router(config)#end
Router#
address ref clock st when poll reach delay offset disp
*~172.25.1.1 130.207.244.240 2 440 1024 377 1.6 -3.23 5.6
+~172.25.1.3 204.152.184.72 2 829 1024 377 1.7 8.06 0.9
* master (synced), # master (unsynced), + selected, - candidate, ~ configured
Router>
Enter configuration commands, one per line. End with CNTL/Z.
Router1(config)#clock timezone EST -5
Router1(config)#clock summer-time EDT recurring
Router1(config)#ntp server 172.25.1.1
Router1(config)#ntp server 172.25.1.2
Router1(config)#interface FastEthernet0/0
Router1(config-if)#ntp broadcast
Router1(config-if)#end
Router1#
客户端
Enter configuration commands, one per line. End with CNTL/Z.
Router2(config)#clock timezone EST -5
Router2(config)#clock summer-time EDT recurring
Router2(config)#interface Ethernet0
Router2(config-if)#ntp broadcast client
Router2(config-if)#end
Router2#
Enter configuration commands, one per line. End with CNTL/Z.
Router1(config)#clock timezone EST -5
Router1(config)#clock summer-time EDT recurring
Router1(config)#ntp server 172.25.1.1
Router1(config)#ntp server 172.25.1.3
Router1(config)#interface FastEthernet 0/0
Router1(config-if)#ntp multicast 224.0.1.1 ttl 1
Router1(config-if)#end
Router1#
Enter configuration commands, one per line. End with CNTL/Z.
Router1(config)#clock timezone EST -5
Router1(config)#clock summer-time EDT recurring
Router1(config)#ntp server 172.25.1.1
Router1(config)#ntp server 172.25.1.3
Router1(config)#interface FastEthernet 0/0
Router1(config-if)#ntp multicast 224.0.1.1 ttl 1
Router1(config-if)#end
Router1#
注释 组播相对于广播的好处不用多说了,并且在这个模式的初始客户端会先发送一些单播包来测量延迟,以使时间更准确,需要注意的是不
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface Serial0/1
Router(config-if)#ntp disable
Router(config-if)#end
Router#
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#access-list 107 deny udp any eq 123 any eq 123
Router(config)#access-list 107 permit ip any any
Router(config)#interface Serial0/1
Router(config-if)#ip access-group 107 in
Router(config-if)#end
Router#
Enter configuration commands, one per line. End with CNTL/Z.
Router1(config)#ntp authentication-key 2 md5 neoshi
Router1(config)#ntp authenticate
Router1(config)#ntp trusted-key 2
Router1(config)#end
Router1#
Enter configuration commands, one per line. End with CNTL/Z.
Router2(config)#ntp authentication-key 2 md5 neoshi
Router2(config)#ntp authenticate
Router2(config)#ntp trusted-key 2
Router2(config)#ntp server 172.25.1.5 key 2
Router2(config)#end
Router2#
注释 对于广播或者组播模式key配置为ntp broadcast key 2 和ntp multicast key 2
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ntp max-associations 30
Router(config)#end
Router#
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#access-list 88 permit host 172.25.1.1
Router(config)#access-list 88 permit host 10.1.1.1
Router(config)#access-list 99 permit 172.25.0.0 0.0.255.255
Router(config)#access-list 99 permit 10.2.0.0 0.0.255.255
Router(config)#clock timezone EST -5
Router(config)#clock summer-time EDT recurring
Router(config)#ntp server 172.25.1.1 version 3
Router(config)#ntp server 10.1.1.1 version 3
Router(config)#ntp access-group peer 88
Router(config)#ntp access-group serve-only 99
Router(config)#end
Router#
ntp clock-period 17180200
Router#
Router>show ntp status
Router>show ntp associations
Router>show ntp associations detail
.Mar 21 02:39:18: NTP: xmit packet to 172.25.1.5:
.Mar 21 02:39:18: leap 3, mode 3, version 3, stratum 0, ppoll 64
.Mar 21 02:39:18: rtdel 28C7 (159.286), rtdsp 2444 (141.663), refid AC190101
.Mar 21 02:39:18: ref C043C43F.47A9CD5C (21:30:23.279 EST Wed Mar 20 2003)
.Mar 21 02:39:18: org 00000000.00000000 (19:00:00.000 EST Thu Dec 31 1899)
.Mar 21 02:39:18: rec 00000000.00000000 (19:00:00.000 EST Thu Dec 31 1899)
.Mar 21 02:39:18: xmt C043C656.4DFC7394 (21:39:18.304 EST Wed Mar 20 2003)
.Mar 21 02:39:25: NTP: rcv packet from 172.25.1.5 to 172.16.2.2 on Fa0/0.1:
.Mar 21 02:39:25: leap 3, mode 3, version 3, stratum 0, ppoll 64
.Mar 21 02:39:25: rtdel 286E (157.928), rtdsp 0EC6 (57.709), refid AC190101
.Mar 21 02:39:25: ref C043C4D7.1D633CDE (21:32:55.114 EST Wed Mar 20 2003)
.Mar 21 02:39:25: org 00000000.00000000 (19:00:00.000 EST Thu Dec 31 1899)
.Mar 21 02:39:25: rec 00000000.00000000 (19:00:00.000 EST Thu Dec 31 1899)
.Mar 21 02:39:25: xmt C043C65D.1D0A6CBC (21:39:25.113 EST Wed Mar 20 2003)
.Mar 21 02:39:25: inp C043C65D.1296E3C7 (21:39:25.072 EST Wed Mar 20 2003)
上面是一个debug的输出,从中看到了来自server的数据包显示为stratum 0,代表服务器没有同步,既然上游服务器没有同步,本地服务
Enter configuration commands, one per line. End with CNTL/Z.
Router2(config)#ntp logging
Router2(config)#end
Router2#
000019: Jan 29 10:57:52.633 EST: %NTP-5-PEERSYNC: NTP synced to peer 172.25.1.5
000020: Jan 29 10:57:52.637 EST: %NTP-6-PEERREACH: Peer 172.25.1.5 is reachable
000024: Jan 29 11:01:20.653 EST: %NTP-4-PEERUNREACH: Peer 172.25.1.5 is unreachable
000026: Jan 29 11:15:11.985 EST: %NTP-4-UNSYNC: NTP sync is lost
在cisco 192.168.10.251上建立NTP服务器
NTP服务器上:
conf t
snmp-server community public ro
ntp autentication-key 1 md5 tschen 7
ntp authenticate
ntp trusted-key 1
ntp source vlan1
ntp master 1
end
conf t
no ntp
ntp authentication-key 1 md5 tschen 7
ntp authenticate
ntp trusted-key 1
ntp server 192.168.10.251 key 1
end
================================================================
路由器的NTP(网络时钟协议)配置
Network Time Protocol(NTP)是用来使计算机时间同步化的一种协议,它可以使计算机对其服务器或时钟源(如石英钟,GPS等等)做同步化
access-list 1 permit 172.16.0.0 0.0.255.255
access-list 2 permit 128.10.39.11
ntp access-group peer 2
ntp access-group serve 1
ntp server 128.105.39.11
Tacoma
ntp server 172.16.1.5
以上配置允许路由器:Settle从一个公共的二级时钟源同步,在与Seattle同一个网络上的另一个路由器Tacoma被允许从Seattle获得同步
NTP 时间时UTC.如果希望路由器保持在另一个时区,你可以使用下列命令保持本地时间:
clock summer-time PDT recurring
使用ntp update-calendar 命令使路由器用NTP获得的时间更新内部日历。
ntp authentication-key number md5 key
ntp trusted-key number
ntp server ip-address key number
ntp authentication 必须配置在NTP服务器和请求时间同步的路由器。(在全局下)。
ntp authencation
ntp authencation-key 10 md5 ntpkey
Tacoma
ntp authencation
ntp authencation-key 10 md5 ntpkey
ntp trusted-key 10
ntp server seattle key 10
Tacoma的ntp server seattle key 10命令指定在Tacoma 与Seattle时钟同步以前,服务器Seattle必须在NTP包中提供10号密码。从Tacoma
sh ntp association detail
===================================================================
Cisco网络环境中的NTP配置[网络时间协议]
在Cisco网络系统中的NTP配置
. NTP 技术概述
. 配置C i s c o路由器为N T P时间服务器
. 配置N T P对等体
. Cisco NTP身份验证
. 配置Cisco NTP用于局域网广播
1引言
网络时间协议( N T P)是用来在整个网络内发布精确时间的T C P / I P协议,其本身的传输基于U D P。本文将探讨Cisco IOS的N T P特性
所有C i s c o路由器都有自己的系统时钟,能够保存当前的日期和时间。N T P主要解决网络 内所有路由器的时钟同步问题,除此之外,它也
——调试与事件时间戳( t i m e s t a m p s):从不同路由器采集的调试与事件时间戳是没有什么意
义的,除非这些路由器是以同一公共时间为参考。
——事物处理:事物处理需要精确的时间戳( t i m e s t a m p s)。
——仿真:复杂的事物往往需细分,由多个系统来处理,为保证事件的正确顺序,多个系统
必须参考同一时钟。
——系统维护:完成某些功能如同时重装( r e l o a d)网络内的所有路由器,整个网络必须拥
有公共时钟。
N T P通常能够使广域网内的所有系统时钟在1 0毫秒内同步。
本节将给出N T P工作原理的简要介绍,有关N T P的详细描述在R F C 1 3 0 5中给出。 N T P所针对的基本问题如图1所示。两台路由器A和B
我们假设:
——在路由器A和B的系统时钟同步之前,路由器A的时钟设定为10:00 a.m.,路由器B的时钟
设定为11:00 a.m.。
——以路由器B为时间服务器(time server),即路由器A将使自己的时钟与路由器B同步。
——数据包在路由器A和B之间单向传输所需的时间为1秒。
——数据包在路由器B内部进行处理的时延为1秒。
1) 路由器A发送一个N T P包给路由器B,该包带有它离开路由器A的时间戳,该时间戳为
10:00:00 a.m.。
2) 当此N T P包到达路由器B时,路由器B加上自己的时间戳,该时间戳为11 : 0 0 : 0 1 a . m .。
3) 当此N T P包离开路由器B时,路由器B再次加上自己的时间戳,该时间戳为11:00:02 a.m.。
4) 当路由器A接收到该响应包时,加上一个新的时间戳,该时间戳为10:00:03 a.m.。
至此,路由器A已拥有足够的信息以计算两个重要的参数:
NTP数据包来回一个周期的时延。
路由器A和路由器B的时钟差。
于是路由器A能够设定自己的时钟与路由器B同步。
应当注意这只是N T P工作原理的一个粗略描述,在R F C 1 3 0 5规范中,N T P使用复杂的算法
来确保时钟同步的精确性。
在实际应用中,通常不会采用路由器来作为N T P服务器,使用商业时钟产品可以获得更
高的时钟精确度。一类该产品如D ATUM Tymserve 2000网络时间服务器,该设备综合了G P S
接收器和N T P服务器的功能,它能够接收G P S网络第1层的时钟信号,以及与以太网相连,响
应来自同位体和客户端的N T P请求。由于这类设备的费用低,也可以用于分布时钟系统(在
本地如大学校园里安放Tymserve 2000)—无需跨过广域网进行时钟同步。
命令的定义
——ntp access-group: 该全局命令用于路由器N T P服务的访问控制。
——ntp authenticate: 是一个全局命令,它启用N T P身份验证。
——ntp authentication-key: 该全局命令用于定义N T P身份验证的键值。
——ntp broadcast: 是一个接口命令,用于指定一特定接口来发送N T P广播包。
——ntp broadcast client: 是一个接口命令,使路由器通过特定接口来接收N T P广播包。
——ntp broadcast delay: 是一个全局命令,它用于设定数据包在路由器和N T P服务器之间一个回程所需时间的估计值。
——ntp clock-period: 这条全局命令不必输入,当使用N T P进行系统时钟同步时,路由器将自动产生这条命令。
——ntp disable: 这条接口命令使特定接口不接收N T P包。
——ntp master: 这条全局命令用来配置路由器为N T P主时钟,只有当没有可用的外部N T P源或者为测试用途才使用该命令。
——ntp peer: 该全局命令使路由器的系统时钟与其对等体的时钟同步(或对对等体的时钟进行同步)。
——ntp server: 该全局命令使路由器的系统时钟由时间服务器进行同步。
——ntp source: 该全局命令强制路由器在其N T P包中使用特定的源地址。
——ntp trusted-key: 该全局命令用于确认路由器的特定身份验证键值。
——ntp update-calendar: 该全局命令使N T P周期性地更新Cisco 7XXX 系列路由器的日历。
——show ntp status: 是一执行模式命令,用于显示路由器的N T P信息,它可以表明该路由器是通过N T P对等体进行时钟同步还是通过N T
——show ntp association[detail]: 这条执行模式命令显示与N T P有关的信息,如*询周期等。
本文的实验使用的是IOS 11 . 2版,这里所讨论的N T P功能大部分可以用IOS 10.0或以后版本进行测试。读者可以到Cisco 网站上查看所拥有
为完成本实验需要下列设备:
1) 三台C i s c o路由器,其中一台有两个串口;
2) Cisco IOS 10.0或更高;
3) 运行终端仿真程序的P C一台;
4) 两根Cisco DTE/DCE交叉电缆,如果没有可用的交叉电缆,可以将标准的Cisco DTE电缆与标准的Cisco DCE电缆相连接做成一条交叉电缆。
本实验将演示两台C i s c o路由器与作为N T P时间服务器的另外一台路由器进行同步,三台 路由器通过串口进行连接,路由器A和B之间、路
C i s c o路由器在加电启动后没有一个有效的日期和时间设置,加电后其时钟被设定为1 9 9 3年3月1日,在N T P生效之前必须为路由器设定
clock set 时:分:秒日月年
本例中三台路由器的配置情况如下:
1. 路由器A
在路由器A会聚和新设定的时钟稳定之后,它将开始传播其时钟设定值。可以用show ntp s t a t u s命令来监测各路由器时钟同步的情况。
在路由器A上执行show ntp status的结果说明它处于同步状态,注意到其参考点显示为“本地”,因为该路由器被设置为主时钟。由于在路由
为完成本实验需要下列设备:
1) 三台C i s c o路由器,其中一台有两个串口;
2) Cisco IOS 10.0或更高;
3) 运行终端仿真程序的P C一台;
4) 两根Cisco DTE/DCE交叉电缆,如果没有可用的交叉电缆,可以将标准的Cisco DTE电缆与标准的Cisco DCE电缆相连接做成一根交叉电缆。
5.2 配置概述
本实验将演示一台C i s c o路由器与作为N T P时间服务器的路由器进行同步,而另外一台路由器则通过与Cisco NTP时间服务器之间对等连接
路由器A被设置为N T P主时钟,路由器B被配置成通过N T P服务器与路由器A进行时钟同步,路由器C则被配置成路由器B的对等体,与B的时钟
C i s c o路由器在加电启动后没有一个有效的日期和时间设置, 加电后其时钟被设定为1 9 9 3年3月1日, 在N T P生效之前必须为路由器设定
clock set 时:分:秒日月年
本实验中三台路由器的配置情况如下(关键N T P命令以加粗字体显示):
1. 路由器A
在路由器A会聚和新设定的时钟稳定之后,它将开始传播其时钟设定值。可以用show ntps t a t u s命令来监测各路由器时钟同步的情况。
在路由器A上执行show ntp status 的结果说明它处于同步状态,注意到其参考点显示为“本地”,因为该路由器被设置为主时钟。由于在路由
==============================================================
Cisco配置NTP服务和协议
ntp autentication-key 1 md5 tschen 7 NTP认证
ntp authenticate NTP认证
ntp trusted-key 1 NTP认证
ntp source vlan1 设置ntp时钟原的端口或IP地址
ntp update-calendar 允许NTP定期更新calendar
ntp master 2 允许本机作为NTP协议的主时钟,精度级别2,供其它对等体同步用
ntp server 202.112.7.150 在网络上指定若干时钟源网站
End
* 客户端:
ntp authentication-key 1 md5 tschen 7
ntp authenticate
ntp trusted-key 1
ntp source vlan1
ntp server 192.168.10.251
end