R1
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Serial1/1
ip address 12.1.1.1 255.255.255.0
serial restart-delay 0
!
router rip
version 2
network 1.0.0.0
network 12.0.0.0
no auto-summary
R2
interface Serial1/0
ip address 12.1.1.2 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
ip address 23.1.1.2 255.255.255.0
serial restart-delay 0
!
router eigrp 10
redistribute rip metric 1000 100 255 1 1500
network 23.1.1.0 0.0.0.255
no auto-summary
!
router rip
version 2
redistribute eigrp 10 metric 1
network 12.0.0.0
no auto-summary
R3
interface Serial1/0
ip address 23.1.1.3 255.255.255.0
serial restart-delay 0
!
router eigrp 10
network 23.1.1.0 0.0.0.255
no auto-summary
查看R3路由表
show ip route
此时在R2 R3上配置
R2
router eigrp 10
eigrp router-id 2.2.2.2
R3
router eigrp 10
eigrp router-id 2.2.2.2
查看R3的路由表
R3学习不到1.1.1.1/32和12.1.1.0/24的路由
总结:
在进行重分发时,如果EIGRP域里面的router-id一样,则无法学到重分发的外部路由。