转自新浪网的danlou747
router>
1:进入特权模式
router > enable
router #
2:进入全局配置模式
router > enable
router #c onfigure terminal
router (conf)#
3:路由器命名 hostname routera
router > enable
router #c onfigure terminal
router(conf)#hostname routerA
routera (conf)#
4:配置使能口令
router > enable
router #c onfigure terminal
router(conf)#hostname routerA
routerA (conf)# enable password cisco
5:配置使能密码
router > enable
router #c onfigure terminal
router(conf)#hostname routerA
routerA (conf)# enable secret ciscolab
6:进入路由器某一端口 interface fastehernet 0/17
router > enable
router #c onfigure terminal
router(conf)#hostname routerA
routerA (conf)# interface fastehernet 0/17
routerA (conf-if)#
进入路由器的某一子端口 interface fastethernet 0/17.1
router > enable
router #c onfigure terminal
router(conf)#hostname routerA
routerA (conf)# interface fastehernet 0/17.1
7:设置端口ip地址信息
router > enable
router #c onfigure terminal
router(conf)#hostname routerA
routerA(conf)# interface fastehernet
routerA (conf-if)#ip address 192.168.1.1 255.255.255.0
routerA (conf-if)#no shut
routerA (conf-if)#exit
8:查看命令
router > enable
router # show version
show interface vlan 1
show running-configure 查看交换机当前起作用的配置信息
show interface fastethernet 0/1
show mac-address-table
show mac-address-table aging-time
9:cdp相关命令
router > enable
router # show cdp
show cdp interface fastethernet 0/17
show cdp traffic
show cdp nerghbors
10:csico2600的密码恢复
重新启动路由器,在启动过程中按下win+break键,使路由器进入rom monitor
在提示符下输入命令修改配置寄存器的值,然后重新启动路由器
remmon1>confreg 0x2142
remmon2>reset
重新启动路由器后进入setup模式,选择“no”,退回到exec模式,此时路由器原有的配置仍然保存在startup-config中,为使路由器恢复密码后配置不变把startup-config中配置保存到running-config中,然后重新设置enable密码,并把配置寄存器改回0x2102:
router>enable
router#copy startup-config running-config
router#c onfigure terminal
router(conf)#enable password cisco
router(conf)#c onfig-register 0x2102
保存当前配置到startup-config , 重新启动路由器。
router #copy running-config startup-config
router #reload
11:路由器telnet远程登录设置:
router>en
router #c onfigure terminal
router (conf)#hostname routerA
routerA (conf)#enable password cisco
routerA (conf)#interface fastethernet 0/1
routerA (conf-if)#ip address 192.168.1.1 255.255.255.0
routerA (conf-if)#no shut
routerA (conf-if)#exit
routerA (conf)line vty 0 4
routerA (conf-line)#login
routerA (conf-line)#password edge
主机设置:
ip
netmask
gate-way
运行:
telnet 192.168.1.1
进入telnet远程登录界面
password : edge
routera>en
password: cisco
routera#
12:配置路由器的标识
在全局配置的模式下利用“banner”命令可以配置路由器的提示信息,所有连接到路由器的终端都会收到。
router>en
router #c onfigure terminal
router (conf)#hostname routerA
routerA(conf)#banner motd $This is aptech company’
13:配置接口标识
接口标识用于区分路由器的各个接口。
router>en
router #c onfigure terminal
router (conf)#hostname routerA
routerA(conf)#interface fastethernet 0/1
routerA(conf-if)# description this is a fast Ethernet port used to connecting the company’s intranet!
14:配置超时
超时适用于设置在多长时间没有对console进行配置,自动返回exec会话时间。默认为10分钟。
router>en
router #c onfigure terminal
router (conf)#hostname routerA
routerA(conf)#line console 0
routerA(conf-if)#e xec-timeout 0 0
15:配置串口参数
两台路由器通过串口连接需要一个做为DTE,一个做为DCE。DCE设备要向DTE设备提供时钟频率和带宽。
DCE配置:
router>en
router #c onfigure terminal
router (conf)#hostname routerA
routerA(conf)#interface serial 0/0
routerA(conf_if)#clock rate 64000
routerA(conf_if)#bandwidth 64
DTE配置:路由器串口配置ip地址
router>en
router #c onfigure terminal
router (conf)#hostname routerB
routerB(conf)#interface serial 0/0
routerB(conf_if)#ip address 192.168.1.1 255.255.255.0
16:静态路由的配置
配置路由器A的主机名和接口参数
router>enable
router#c onfigure terminal
router(conf)#hostname routerA
routerA(conf)#interface fastethernet 0/1
routerA(conf-if)#ip address 192.168.2.1 255.255.255.0
routerA(conf-if)#no shutdown
routerA(conf-if)#exit
routerA(conf)# interface fastethernet 0/0
routerA(conf-if)#ip address 192.168.1.2 255.255.255.0
routerA(conf-if)#no shutdown
主机A的ip地址为 192.168.1.1
255.255.255.0
192.168.1.2
配置路由器B的主机名和接口参数
router>enable
router#c onfigure terminal
router(conf)#hostname routerB
routerB(conf)#interface fastethernet 0/0
routerB(conf-if)#ip address 192.168.2.2 255.255.255.0
routerB(conf-if)#no shutdown
routerB (conf-if)#exit
routerB(conf)# interface fastethernet 0/1
routerB(conf-if)#ip address 192.168.3.1 255.255.255.0
主机B的ip地址为 192.168.3.2
255.255.255.0
192.168.3.1
配置路由器A的静态路由表
routerA(conf)#ip router 192.168.3.0
配置路由器B的静态路由表
routerA(conf)#ip router 192.168.1.0
在routerA和routerB上配置默认路由
routerA(conf)#ip route 0.0.0.0 0.0.0.0 192.168.2.2
routerA(conf)#ip classless
routerB(conf)#ip route 0.0.0.0 0.0.0.0 192.168.2.1
routerB(conf)#ip classless
在routerA和routerB上配置动态路由(RIP)
routerA(conf)#router rip
routerA(conf)#network 192.168.1.0
routerA(conf)#network 192.168.2.0
routerB(conf)# router rip
routerB(conf)#network 192.168.2.0
routerB(conf)#network 192.168.3.0
在routerA和routerB上配置浮动路由
routerA(conf)#ip route 192.168.1.2 255.255.255.0 192.168.2.1 150 |
路由器配置命令大全
精选 转载路由器配置命令大全
2010-04-20 09:09
上一篇:免费的家用电脑反病毒保护软件
下一篇:系统文件大全
提问和评论都可以,用心的回复会被更多人看到
评论
发布评论
相关文章
-
Cisco路由器常用查看命令
Cisco路由器常用查看命令
链路 加解密 路由表 Cisco路由器常用查看命令】 -
路由器配置大全
交换机口令设置:switch>enable &n
交换机 路由器 password secret enable -
华为路由器命令大全
[Quidway]dis cur &nbs
华为 命令 路由器 大全 休闲