ipv6 unicast-routing
!
interface Loopback0
no ip address
ipv6 address 2001::1/128
ipv6 ospf 1 area 0
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2002:202:202::1/64
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
!
ipv6 router ospf 1
router-id 1.1.1.1
ipv6 unicast-routing
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Tunnel0
no ip address
no ip redirects
ipv6 unnumbered FastEthernet0/0 借用了f0/0的地址
tunnel source Loopback0 以lo0做源
tunnel mode ipv6ip 6to4 tunnel模式为6to4
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2002:202:202::2/64(tunnel借用了f0/0的地址,所以f0/0的地址前缀必须嵌入源lo0的地址 )
ipv6 ospf 1 area 0
!
interface FastEthernet1/0
ip address 23.1.1.2 255.255.255.0
duplex auto
speed auto
!
router ospf 2
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 23.1.1.0 0.0.0.255 area 0
!
ipv6 route 2002::/16 Tunnel0
ipv6 route ::/0 2002:303::303::3 注解(1)
ipv6 router ospf 1
router-id 2.2.2.2
log-adjacency-changes
default-information originate
redistribute static
hostname R3
ipv6 unicast-routing
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Tunnel0
no ip address
no ip redirects
ipv6 unnumbered FastEthernet0/0
tunnel source Loopback0
tunnel mode ipv6ip 6to4
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2002:303:303::3/64
ipv6 ospf 1 area 0
!
interface FastEthernet1/0
ip address 23.1.1.3 255.255.255.0
duplex auto
speed auto
!
router ospf 2
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 23.1.1.0 0.0.0.255 area 0
!
ipv6 route 2002::/16 Tunnel0
ipv6 router ospf 1
router-id 3.3.3.3
log-adjacency-changes
redistribute static
!
interface Loopback0
no ip address
ipv6 address 2001::4/128
!
interface FastEthernet0/0o ip address
duplex auto
speed auto
ipv6 address 2002:303:303::4/64
ipv6 ospf 1 area 0
!
interface FastEthernet1/0
no ip address
shutdown
duplex auto
speed auto
ipv6 router ospf 1
router-id 4.4.4.4