ip address 10.1.1.1 255.255.255.0
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/0
no ip address
ip virtual-reassembly
duplex auto
speed auto
pppoe enable //起用pppoe协议
pppoe-client dial-pool-number 1 //dial-pool-number 1必须与dialer接口定义的dialer pool 一样
!
interface Dialer1
mtu 1482
ip address negotiated //使用IP协商
ip nat outside //定义NAT OUTSIDE接口
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username username@dsl password 88888888
!
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 100 permit ip 172.16.1.0 0.0.0.255 any
dialer-list 1 protocol ip permit