实验拓扑图:

 

EIGRP的基础配置_EIGRP

实验过程

 

1.R1的预配置

Router>en

Router#config t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#no ip domain-lookup

Router(config)#line console 0

Router(config-line)#no exec-timeout

Router(config-line)#loggin syn

Router(config-line)#exit

Router(config)#host R1

R1(config)#interface s1/0

R1(config-if)#no shut

R1(config-if)#ip add 192.168.0.1 255.255.255.0

R1(config-if)#exit

2.R2的预配置

Router>en

Router#config t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#no ip domain-lookup

Router(config)#line console 0

Router(config-line)#no exec-timeout

Router(config-line)#loggin syn

Router(config-line)#exit

Router(config)#host R2

R2(config)#interface s1/0

R2(config-if)#no shut

R2(config-if)#ip add 192.168.0.2 255.255.255.0

R2(config-if)#exit

R2(config)#interface s1/1

R2(config-if)#no shut

R2(config-if)#ip add 172.16.0.1 255.255.255.0

R2(config-if)#exit

3.R3的预配置

Router>en

Router#config t

Enter configuration commands, one per line.  End with CNTL/Z.

Router(config)#no ip domain-lookup

Router(config)#line console 0

Router(config-line)#no exec-timeout

Router(config-line)#loggin syn

Router(config-line)#exit

Router(config)#host R3

R3(config)#interface s1/1

R3(config-if)#no shut

R3(config-if)#ip add 172.16.0.2 255.255.255.0

R3(config-if)#exit

4.R1配置EIGRP

R1(config)#router eigrp 100  //启动eigrpAS 100

R1(config-router)#network 192.168.0.1 0.0.0.0  //使用反掩码宣告准确网络

R1(config-router)#no auto  //关闭自动汇总

R1(config-router)#end 

5.R2配置EIGRP

R2(config)#router eigrp 100

R2(config-router)#network 192.168.0.2 0.0.0.0

R2(config-router)#network 172.16.0.1 0.0.0.0

R2(config-router)#no auto

R2(config-router)#end

6.R3配置EIGRP

R3(config)#router eigrp 100

R3(config-router)#network 172.16.0.2 //不使用反掩码宣告网络

R3(config-router)#no auto

R3(config-router)#end

7.查看协议信息

R1#show ip protocols

Routing Protocol is "eigrp 100"

  Outgoing update filter list for all interfaces is not set

  Incoming update filter list for all interfaces is not set

  Default networks flagged in outgoing updates

  Default networks accepted from incoming updates

  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0

  EIGRP maximum hopcount 100  //EIGRP最大支持100

  EIGRP maximum metric variance 1

  Redistributing: eigrp 100

  EIGRP NSF-aware route hold timer is 240s

  Automatic network summarization is not in effect

  Maximum path: 4

  Routing for Networks:

    192.168.0.1/32  //使用32位前缀精确宣告

  Routing Information Sources:

    Gateway         Distance      Last Update

    192.168.0.2           90      00:06:16

  Distance: internal 90 external 170

R3#show ip protocols

Routing Protocol is "eigrp 100"

  Outgoing update filter list for all interfaces is not set

  Incoming update filter list for all interfaces is not set

  Default networks flagged in outgoing updates

  Default networks accepted from incoming updates

  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0

  EIGRP maximum hopcount 100

  EIGRP maximum metric variance 1

  Redistributing: eigrp 100

  EIGRP NSF-aware route hold timer is 240s

  Automatic network summarization is not in effect

  Maximum path: 4

  Routing for Networks:

    172.16.0.0  //宣告不带反掩码会自动汇总成有类网络

  Routing Information Sources:

    Gateway         Distance      Last Update

    172.16.0.1            90      00:07:04

  Distance: internal 90 external 170

8.查看eigrp的邻居表

R2#show ip eigrp nei

IP-EIGRP neighbors for process 100

H   Address               Interface       Hold Uptime   SRTT   RTO  Q  Seq

                                            (sec)         (ms)       Cnt Num

1   172.16.0.2              Se1/1             13 00:00:11  116   696  0  3

0   192.168.0.1             Se1/0             11 00:01:03  104   624  0  3

9.查看eigrp路由表

R1#show ip route eigrp

     172.16.0.0/24 is subnetted, 1 subnets

D       172.16.0.0 [90/2681856] via 192.168.0.2, 00:10:17, Serial1/0  //EIGRP学习到的路由用“D来表示。”

R3#show ip route eigrp

D    192.168.0.0/24 [90/2681856] via 172.16.0.1, 00:10:02, Serial1/1