实验指南实验指南:RIP在网络中的应用_休闲
 
Use the IP subnet 150.100.100.0/24 for the Frame Relay network between the habanos, montecristo, and romeo_y_julieta routers. Use RIP as the routing protocol. Ensure that montecristo has IP connectivity to romeo_y_julieta.
 
Use the IP subnet of 150.100.200.0/30 for the Frame Relay link between the habanos and churchill_imports router. Use EIGRP with 2001 as the autonomous system for the routing protocol.

Mutually redistribute RIP into EIGRP on the habanos router. Ensure full IP reachability across the entire network.

Prevent the subnet 150.100.10.0/24 on the habanos router from reaching montecristo and romeo_y_julieta.

(Optional) Configure the habanos router so that all routes from romeo_y_julieta have an administrative distance of 5.
 
 
Habanos
conf t
hostname Habanos
int l 0
ip ad 150.100.10.1 255.255.255.0
int s2/0
encap f
no arp f
no shut
int s 2/0.1 multipoint
ip ad 150.100.100.1 255.255.255.0
no arp f
no frame inver
frame map ip 150.100.100.2 102 b
frame map ip 150.100.100.3 103 b
int s 2/0.2 point-to-point
ip ad 150.100.200.1 255.255.255.252
frame interface-dlci 104
router rip
ver 2
no au
net 150.100.0.0
redistribute eigrp 2001 metric 5
distribute-list 1 out s2/0.1
distance 5 150.100.100.3 0.0.0.0 2
router eigrp 2001
no au
net 150.100.200.1 0.0.0.0
redistribute rip metric 10000 100 255 1 1500
access-list 1 deny 150.100.10.0 0.0.0.255
access-list 1 permit any
access-list 2 permit 150.100.2.0 0.0.0.0
end

Montecristo
conf t
host Montecristo
int l 0
ip ad 150.100.1.1 255.255.255.0
int s 2/0
ip ad 150.100.100.2 255.255.255.0
encap f
no arp f
no frame inver
frame map ip 150.100.100.1 201 b
frame map ip 150.100.100.3 201 b
no shut
router rip
ver 2
no au
net 150.100.0.0
end

Romeo_y_julieta
conf t
host Romeo_y_julieta
int  l 0
ip ad 150.100.2.1 255.255.255.0
int s2/0
ip ad 150.100.100.3 255.255.255.0
encap f
no arp f
no frame inver
frame map ip 150.100.100.1 301 b
frame map ip 150.100.100.2 301 b
no shut
router rip
ver 2
no au
net 150.100.0.0
end

Churchil_imports
conf t
host Churchill
int l 0
ip ad 150.100.3.1 255.255.255.0
int s 2/0
ip ad 150.100.200.2 255.255.255.252
encap f
no arp f
no frame inver
frame map ip 150.100.200.1 401 b
no shut
router eigrp 2001
no au
net 150.100.200.2 0.0.0.0
net 150.100.3.1 0.0.0.0
end
 
校验
Habanos(config)#do sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     150.100.0.0/16 is variably subnetted, 6 subnets, 2 masks
C       150.100.200.0/30 is directly connected, Serial2/0.2
C       150.100.100.0/24 is directly connected, Serial2/0.1
R       150.100.2.0/24 [5/1] via 150.100.100.3, 00:00:18, Serial2/0.1
D       150.100.3.0/24 [90/2297856] via 150.100.200.2, 00:23:34, Serial2/0.2
R       150.100.1.0/24 [120/1] via 150.100.100.2, 00:00:06, Serial2/0.1
C       150.100.10.0/24 is directly connected, Loopback0
 
在做路由过滤前
Montecristo(config-router)#do sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     150.100.0.0/16 is variably subnetted, 5 subnets, 2 masks
R       150.100.200.0/30 [120/1] via 150.100.100.1, 00:00:26, Serial2/0
C       150.100.100.0/24 is directly connected, Serial2/0
R       150.100.3.0/24 [120/5] via 150.100.100.1, 00:00:26, Serial2/0
C       150.100.1.0/24 is directly connected, Loopback0
R       150.100.10.0/24 [120/1] via 150.100.100.1, 00:01:25, Serial2/0
 
过滤后
Montecristo(config-router)#do sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     150.100.0.0/16 is variably subnetted, 4 subnets, 2 masks
R       150.100.200.0/30 [120/1] via 150.100.100.1, 00:00:04, Serial2/0
C       150.100.100.0/24 is directly connected, Serial2/0
R       150.100.3.0/24 [120/5] via 150.100.100.1, 00:00:04, Serial2/0
C       150.100.1.0/24 is directly connected, Loopback0
 
Churchill(config-router)#do sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     150.100.0.0/16 is variably subnetted, 6 subnets, 2 masks
C       150.100.200.0/30 is directly connected, Serial2/0
D EX    150.100.100.0/24 [170/2195456] via 150.100.200.1, 00:12:37, Serial2/0
D EX    150.100.2.0/24 [170/2195456] via 150.100.200.1, 00:12:37, Serial2/0
C       150.100.3.0/24 is directly connected, Loopback0
D EX    150.100.1.0/24 [170/2195456] via 150.100.200.1, 00:12:37, Serial2/0
D EX    150.100.10.0/24 [170/2195456] via 150.100.200.1, 00:12:37, Serial2/0